summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-07-17 08:59:43 +0300
committerDimitris Kiziridis2020-07-17 08:59:43 +0300
commit4f78ef55aa372ce486c207d7a689aade1b3b93da (patch)
treeef6526dd8a05c2d090648d07ea7cbd88e929ba8d
parentcdbf4c9d979e4d684e2d9e48b24fce77766b261f (diff)
downloadaur-4f78ef55aa372ce486c207d7a689aade1b3b93da.tar.gz
restructure package
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 7 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e25fc5e80c77..cc21e9b7e0cd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,12 +3,10 @@ pkgbase = hyperkeys-bin
pkgver = 1.1.7
pkgrel = 1
url = https://hyperkeys.xureilab.com
- arch = any
+ arch = x86_64
license = GPL3
- depends = zlib
provides = hyperkeys
noextract = hyperkeys-bin-1.1.7.AppImage
- options = !strip
source = hyperkeys-bin-1.1.7.AppImage::https://github.com/xurei/hyperkeys/releases/download/v1.1.7/HyperKeys-1.1.7.AppImage
sha256sums = 21391eda00318d1397b14b736d10f6619af84385281a7fa10699c06ad8a016ae
diff --git a/PKGBUILD b/PKGBUILD
index 6131d6736262..f1ccbef0ad38 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,10 @@ pkgname=hyperkeys-bin
pkgver=1.1.7
pkgrel=1
pkgdesc="Unleash you keyboard shorcuts"
-arch=('any')
+arch=('x86_64')
url='https://hyperkeys.xureilab.com'
license=('GPL3')
provides=('hyperkeys')
-depends=('zlib')
-options=('!strip')
noextract=("${pkgname}-${pkgver}.AppImage")
source=("${pkgname}-${pkgver}.AppImage::https://github.com/xurei/hyperkeys/releases/download/v${pkgver}/HyperKeys-${pkgver}.AppImage")
sha256sums=('21391eda00318d1397b14b736d10f6619af84385281a7fa10699c06ad8a016ae')
@@ -23,10 +21,12 @@ package() {
--name "HyperKeys" \
--comment "$pkgdesc" \
--exec "${pkgname%-bin}" \
- --categories 'Utility;Application;' \
+ --categories 'Utility;Application' \
--icon "${pkgname%-bin}"
install -Dm644 "${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
install -d "${pkgdir}/usr/bin"
- install -Dm755 "${srcdir}/${pkgname}-${pkgver}.AppImage" "${pkgdir}/usr/share/${pkgname%-bin}/${pkgname%-bin}.AppImage"
- ln -s /usr/share/hyperkeys/${pkgname%-bin}.AppImage "${pkgdir}/usr/bin/hyperkeys"
+ install -d "${pkgdir}/opt"
+ cp -avR squashfs-root/ "${pkgdir}/opt/${pkgname%-bin}"
+ ln -s /opt/${pkgname%-bin}/AppRun "${pkgdir}/usr/bin/hyperkeys"
+ find "${pkgdir}/opt/${pkgname%-bin}" -type d -exec chmod 755 {} +
} \ No newline at end of file