summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-02-04 12:22:09 +0800
committerzxp198210052024-02-04 12:22:09 +0800
commit803378173a4437c572d3e79b3158cd3884c00336 (patch)
treedd9cdec36f5b198bf1d15782276f40d49ab773c7
parent068d9cb6541f03f2348b8c2b4023e672ab62f489 (diff)
downloadaur-803378173a4437c572d3e79b3158cd3884c00336.tar.gz
fix errors
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD26
-rw-r--r--hyperkeys.sh11
3 files changed, 21 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e8d634e4b967..f05b9ba31068 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,31 +1,23 @@
pkgbase = hyperkeys-bin
pkgdesc = Unleash you keyboard shorcuts
pkgver = 1.3.0
- pkgrel = 5
+ pkgrel = 6
url = https://hyperkeys.xureilab.com/
arch = x86_64
- license = GPL3
+ license = GPL-3.0-only
makedepends = squashfuse
depends = electron20
- depends = libx11
- depends = gdk-pixbuf2
- depends = libxext
- depends = libdbusmenu-glib
- depends = gtk2
depends = dbus-glib
- depends = libxcb
- depends = expat
- depends = pango
- depends = cairo
- depends = at-spi2-core
+ depends = libdbusmenu-glib
depends = gtk3
+ depends = gtk2
depends = java-runtime
- depends = libxmu
- depends = libdbusmenu-gtk3
- depends = xdotool
depends = perl
depends = python
depends = nodejs
+ depends = libdbusmenu-gtk3
+ depends = libxmu
+ depends = xdotool
provides = hyperkeys=1.3.0
conflicts = hyperkeys
options = !emptydirs
@@ -33,6 +25,6 @@ pkgbase = hyperkeys-bin
source = hyperkeys-1.3.0.AppImage::https://github.com/xurei/hyperkeys/releases/download/v1.3.0/HyperKeys-1.3.0.AppImage
source = hyperkeys.sh
sha256sums = 2884e6025aa4dfee198f1279584e8ec798d8f9519cbe8c6ed1f4648b26e63711
- sha256sums = 5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf
+ sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014
pkgname = hyperkeys-bin
diff --git a/PKGBUILD b/PKGBUILD
index d54ba855c08b..34f0e5eb60f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,35 +4,27 @@ pkgname=hyperkeys-bin
_appname=HyperKeys
pkgver=1.3.0
_electronversion=20
-pkgrel=5
+pkgrel=6
pkgdesc="Unleash you keyboard shorcuts"
arch=('x86_64')
url="https://hyperkeys.xureilab.com/"
_ghurl="https://github.com/xurei/hyperkeys"
-license=('GPL3')
+license=('GPL-3.0-only')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
"electron${_electronversion}"
- 'libx11'
- 'gdk-pixbuf2'
- 'libxext'
- 'libdbusmenu-glib'
- 'gtk2'
'dbus-glib'
- 'libxcb'
- 'expat'
- 'pango'
- 'cairo'
- 'at-spi2-core'
+ 'libdbusmenu-glib'
'gtk3'
+ 'gtk2'
'java-runtime'
- 'libxmu'
- 'libdbusmenu-gtk3'
- 'xdotool'
'perl'
'python'
'nodejs'
+ 'libdbusmenu-gtk3'
+ 'libxmu'
+ 'xdotool'
)
makedepends=(
'squashfuse'
@@ -46,11 +38,11 @@ source=(
"${pkgname%-bin}.sh"
)
sha256sums=('2884e6025aa4dfee198f1279584e8ec798d8f9519cbe8c6ed1f4648b26e63711'
- '5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf')
+ '0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
- -e "s|@appasar@|app|g" \
+ -e "s|@runname@|app|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
diff --git a/hyperkeys.sh b/hyperkeys.sh
index c77c53567639..f9ced1432cfc 100644
--- a/hyperkeys.sh
+++ b/hyperkeys.sh
@@ -1,17 +1,14 @@
#!/bin/sh
set -e
_APPDIR="/usr/lib/@appname@"
-_ASAR="${_APPDIR}/@appasar@"
+_RUNNAME="${_APPDIR}/@runname@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
export NODE_ENV=production
+cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- cd "${_APPDIR}"
- exec electron@electronversion@ "${_ASAR}" "$@"
- exit
+ exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
else
- cd "${_APPDIR}"
- exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
- exit
+ exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file