summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-05-29 22:57:11 +0300
committerDimitris Kiziridis2020-05-29 22:57:11 +0300
commitc5ff663475e935c14dcd0d567d707328e54cd039 (patch)
tree4847a92aa03ad890d9684edbf4b4f892b5b49b52
downloadaur-c5ff663475e935c14dcd0d567d707328e54cd039.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5fd73780d7d6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = hyperkeys-bin
+ pkgdesc = Unleash you keyboard shorcuts
+ pkgver = 1.1.7
+ pkgrel = 1
+ url = https://hyperkeys.xureilab.com
+ arch = any
+ license = GPL3
+ depends = zlib
+ noextract = hyperkeys-bin-1.1.7.AppImage
+ options = !strip
+ source = hyperkeys-bin-1.1.7.AppImage::https://github.com/xurei/hyperkeys/releases/download/v1.1.7/HyperKeys-1.1.7.AppImage
+ sha256sums = 21391eda00318d1397b14b736d10f6619af84385281a7fa10699c06ad8a016ae
+
+pkgname = hyperkeys-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..54b9fea9d04f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=hyperkeys-bin
+pkgver=1.1.7
+pkgrel=1
+pkgdesc="Unleash you keyboard shorcuts"
+arch=('any')
+url='https://hyperkeys.xureilab.com'
+license=('GPL3')
+depends=('zlib')
+options=('!strip')
+noextract=("${pkgname}-${pkgver}.AppImage")
+source=("${pkgname}-${pkgver}.AppImage::https://github.com/xurei/hyperkeys/releases/download/v${pkgver}/HyperKeys-${pkgver}.AppImage")
+sha256sums=('21391eda00318d1397b14b736d10f6619af84385281a7fa10699c06ad8a016ae')
+
+package() {
+ chmod 755 ./${pkgname}-${pkgver}.AppImage
+ ./${pkgname}-${pkgver}.AppImage --appimage-extract
+ install -Dm644 squashfs-root/resources/app/icon.png "${pkgdir}/usr/share/pixmaps/hyperkeys.png"
+ gendesk -f -n --pkgname "${pkgname%-bin}" \
+ --pkgdesc "$pkgdesc" \
+ --name "HyperKeys" \
+ --comment "$pkgdesc" \
+ --exec "${pkgname%-bin}" \
+ --categories 'Utility;Application;' \
+ --icon "${pkgname%-bin}"
+ install -Dm644 "${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
+ install -d "${pkgdir}/usr/bin"
+ install -Dm755 "${srcdir}/${pkgname}-${pkgver}.AppImage" "${pkgdir}/usr/share/${pkgname%-bin}/${pkgname%-bin}.AppImage"
+ ln -s /usr/share/hyperkeys/${pkgname%-bin}.AppImage "${pkgdir}/usr/bin/hyperkeys"
+} \ No newline at end of file