summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-06 09:18:48 +0800
committerzxp198210052024-03-06 09:18:48 +0800
commitfba851cb378f1e51616559b88b33845a5ba41e64 (patch)
tree55808204459dc10b8ba8f5ad9b943390e6b3f0a2
parent803378173a4437c572d3e79b3158cd3884c00336 (diff)
downloadaur-fba851cb378f1e51616559b88b33845a5ba41e64.tar.gz
fix errors
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD16
-rw-r--r--hyperkeys.sh3
3 files changed, 14 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f05b9ba31068..924d44ccafca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,19 @@
pkgbase = hyperkeys-bin
pkgdesc = Unleash you keyboard shorcuts
pkgver = 1.3.0
- pkgrel = 6
+ pkgrel = 7
url = https://hyperkeys.xureilab.com/
arch = x86_64
license = GPL-3.0-only
- makedepends = squashfuse
+ makedepends = fuse2
depends = electron20
- depends = dbus-glib
- depends = libdbusmenu-glib
- depends = gtk3
- depends = gtk2
depends = java-runtime
depends = perl
- depends = python
+ depends = python>3
depends = nodejs
- depends = libdbusmenu-gtk3
- depends = libxmu
+ depends = libdbusmenu-glib
depends = xdotool
+ depends = libxmu
provides = hyperkeys=1.3.0
conflicts = hyperkeys
options = !emptydirs
@@ -25,6 +21,6 @@ pkgbase = hyperkeys-bin
source = hyperkeys-1.3.0.AppImage::https://github.com/xurei/hyperkeys/releases/download/v1.3.0/HyperKeys-1.3.0.AppImage
source = hyperkeys.sh
sha256sums = 2884e6025aa4dfee198f1279584e8ec798d8f9519cbe8c6ed1f4648b26e63711
- sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014
+ sha256sums = 50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe
pkgname = hyperkeys-bin
diff --git a/PKGBUILD b/PKGBUILD
index 34f0e5eb60f0..319524db9545 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgname=hyperkeys-bin
_appname=HyperKeys
pkgver=1.3.0
_electronversion=20
-pkgrel=6
+pkgrel=7
pkgdesc="Unleash you keyboard shorcuts"
arch=('x86_64')
url="https://hyperkeys.xureilab.com/"
@@ -14,20 +14,16 @@ provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
"electron${_electronversion}"
- 'dbus-glib'
- 'libdbusmenu-glib'
- 'gtk3'
- 'gtk2'
'java-runtime'
'perl'
- 'python'
+ 'python>3'
'nodejs'
- 'libdbusmenu-gtk3'
- 'libxmu'
+ 'libdbusmenu-glib'
'xdotool'
+ 'libxmu'
)
makedepends=(
- 'squashfuse'
+ 'fuse2'
)
options=(
'!emptydirs'
@@ -38,7 +34,7 @@ source=(
"${pkgname%-bin}.sh"
)
sha256sums=('2884e6025aa4dfee198f1279584e8ec798d8f9519cbe8c6ed1f4648b26e63711'
- '0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
+ '50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
diff --git a/hyperkeys.sh b/hyperkeys.sh
index f9ced1432cfc..86cb3dc6a9bf 100644
--- a/hyperkeys.sh
+++ b/hyperkeys.sh
@@ -1,10 +1,11 @@
-#!/bin/sh
+#!/bin/bash
set -e
_APPDIR="/usr/lib/@appname@"
_RUNNAME="${_APPDIR}/@runname@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
+export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then