summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302018-02-22 12:39:27 +0100
committerM0Rf302018-02-22 12:39:27 +0100
commit28d38ae2bf40e6bd4e9bde0d9746b42b0522e9a2 (patch)
tree04014ca29d83102134332e54ba7721b68bfeede2
parent82ba00885ac67f96dbd5db4ed1d494247ecc5920 (diff)
downloadaur-28d38ae2bf40e6bd4e9bde0d9746b42b0522e9a2.tar.gz
hyperledger-fabric: 1.0.6
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD68
2 files changed, 38 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ed50d282dde3..9ac2a788b6d7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = hyperledger-fabric
pkgdesc = A platform for distributed ledger solutions, underpinned by a modular architecture delivering high degrees of confidentiality, resiliency, flexibility and scalability
- pkgver = 1.0.5
- pkgrel = 2
+ pkgver = 1.0.6
+ pkgrel = 1
url = https://github.com/hyperledger/fabric
install = hyperledger-fabric.install
arch = armv6h
@@ -15,11 +15,11 @@ pkgbase = hyperledger-fabric
makedepends = git
makedepends = docker
depends = go
- source = https://github.com/hyperledger/fabric/archive/v1.0.5.tar.gz
+ source = https://github.com/hyperledger/fabric/archive/v1.0.6.tar.gz
source = fabric-peer.conf
source = fabric-peer.service
source = arm-support.patch
- md5sums = f2f2f3099eed8bbe593b8ece4851b776
+ md5sums = 0a114daece3c8851c8964aea57798f32
md5sums = a0bafaaeb3be191ed2893662fe9a6fc7
md5sums = 19a55d9a62f467235b51b2e4d7b3c523
md5sums = 2e0e11a95f75e66b08206b685d21eb36
diff --git a/PKGBUILD b/PKGBUILD
index 8dc75514cdd9..cbfedf7bcfb0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
_pkgname=fabric
pkgname=hyperledger-${_pkgname}
-pkgver=1.0.5
-pkgrel=2
+pkgver=1.0.6
+pkgrel=1
pkgdesc="A platform for distributed ledger solutions, underpinned by a modular architecture delivering high degrees of confidentiality, resiliency, flexibility and scalability"
arch=(armv6h armv7h arm aarch64 i686 x86_64)
url="https://github.com/hyperledger/fabric"
@@ -13,52 +13,52 @@ depends=('go')
makedepends=('git' 'docker')
install=$pkgname.install
source=("https://github.com/hyperledger/fabric/archive/v$pkgver.tar.gz"
- ${_pkgname}-peer.conf
- ${_pkgname}-peer.service
- arm-support.patch)
+ ${_pkgname}-peer.conf
+ ${_pkgname}-peer.service
+arm-support.patch)
export GOOS=linux
case "$CARCH" in
- x86_64) export GOARCH=amd64 ;;
- i686) export GOARCH=386 GO386=387 ;;
- arm) export GOARCH=arm GOARM=5 ;;
- armv6h) export GOARCH=arm GOARM=6 ;;
- armv7h) export GOARCH=arm GOARM=7 ;;
- aarch64) export GOARCH=arm64 ;;
+ x86_64) export GOARCH=amd64 ;;
+ i686) export GOARCH=386 GO386=387 ;;
+ arm) export GOARCH=arm GOARM=5 ;;
+ armv6h) export GOARCH=arm GOARM=6 ;;
+ armv7h) export GOARCH=arm GOARM=7 ;;
+ aarch64) export GOARCH=arm64 ;;
esac
prepare() {
- cd $srcdir/${_pkgname}-$pkgver
- patch -Np1 -i ../arm-support.patch
- cd ..
- export GOPATH="$PWD"/.gopath
- mkdir -p "$GOPATH"/src/github.com/hyperledger
- ln -sf "$PWD"/fabric-$pkgver "$GOPATH"/src/github.com/hyperledger/fabric
+ cd $srcdir/${_pkgname}-$pkgver
+ patch -Np1 -i ../arm-support.patch
+ cd ..
+ export GOPATH="$PWD"/.gopath
+ mkdir -p "$GOPATH"/src/github.com/hyperledger
+ ln -sf "$PWD"/fabric-$pkgver "$GOPATH"/src/github.com/hyperledger/fabric
}
build() {
- export GOPATH="$PWD"/.gopath
- cd "$GOPATH"/src/github.com/hyperledger/fabric
- make release/linux-$GOARCH
+ export GOPATH="$PWD"/.gopath
+ cd "$GOPATH"/src/github.com/hyperledger/fabric
+ make release/linux-$GOARCH
}
package() {
- cd $srcdir/${_pkgname}-$pkgver
- install -Dm 644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE
- install -Dm 644 -t "$pkgdir/usr/share/doc/$pkgname" README.md
+ cd $srcdir/${_pkgname}-$pkgver
+ install -Dm 644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE
+ install -Dm 644 -t "$pkgdir/usr/share/doc/$pkgname" README.md
- cp -r release/linux-$GOARCH/bin "$pkgdir/usr"
- install -dm 755 $pkgdir/etc/hyperledger/fabric/tls
- cp -r sampleconfig/* $pkgdir/etc/hyperledger/fabric
+ cp -r release/linux-$GOARCH/bin "$pkgdir/usr"
+ install -dm 755 $pkgdir/etc/hyperledger/fabric/tls
+ cp -r sampleconfig/* $pkgdir/etc/hyperledger/fabric
-msg2 "Install systemd service"
- install -Dm644 $srcdir/${_pkgname}-peer.service $pkgdir/usr/lib/systemd/system/${_pkgname}-peer.service
+ msg2 "Install systemd service"
+ install -Dm644 $srcdir/${_pkgname}-peer.service $pkgdir/usr/lib/systemd/system/${_pkgname}-peer.service
-msg2 "Install conf file"
- install -Dm644 $srcdir/${_pkgname}-peer.conf $pkgdir/usr/lib/environment.d/${_pkgname}-peer.conf
+ msg2 "Install conf file"
+ install -Dm644 $srcdir/${_pkgname}-peer.conf $pkgdir/usr/lib/environment.d/${_pkgname}-peer.conf
}
-md5sums=('f2f2f3099eed8bbe593b8ece4851b776'
- 'a0bafaaeb3be191ed2893662fe9a6fc7'
- '19a55d9a62f467235b51b2e4d7b3c523'
- '2e0e11a95f75e66b08206b685d21eb36')
+md5sums=('0a114daece3c8851c8964aea57798f32'
+ 'a0bafaaeb3be191ed2893662fe9a6fc7'
+ '19a55d9a62f467235b51b2e4d7b3c523'
+'2e0e11a95f75e66b08206b685d21eb36')