summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302017-07-27 14:15:07 +0200
committerM0Rf302017-07-27 14:15:07 +0200
commit2f8b0c44e4f1f49c7569d3a0fb1b5b69c6bce843 (patch)
treedff208f24a6f0dd88226fcd6bddbf7f52e20d367
downloadaur-2f8b0c44e4f1f49c7569d3a0fb1b5b69c6bce843.tar.gz
hyperledger-fabric: 1.0.0
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD34
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..af251acf9720
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Thu Jul 27 12:14:59 UTC 2017
+pkgbase = hyperledger-fabric
+ pkgdesc = A platform for distributed ledger solutions, underpinned by a modular architecture delivering high degrees of confidentiality, resiliency, flexibility and scalability
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/hyperledger/fabric
+ arch = x86_64
+ groups = hyperledger-fabric
+ license = APACHE
+ depends = go
+ source = https://github.com/hyperledger/fabric/archive/v1.0.0.tar.gz
+ md5sums = a3b3b80224c88fe984207e6321ccdb04
+
+pkgname = hyperledger-fabric
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..713dc25f7ca0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: M0Rf30
+
+_pkgname=fabric
+pkgname=hyperledger-${_pkgname}
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="A platform for distributed ledger solutions, underpinned by a modular architecture delivering high degrees of confidentiality, resiliency, flexibility and scalability"
+arch=(x86_64)
+url="https://github.com/hyperledger/fabric"
+license=('APACHE')
+groups=('hyperledger-fabric')
+depends=('go')
+source=("https://github.com/hyperledger/fabric/archive/v$pkgver.tar.gz")
+
+prepare() {
+ export GOPATH="$PWD"/.gopath
+ mkdir -p "$GOPATH"/src/github.com/hyperledger
+ ln -sf "$PWD"/fabric-$pkgver "$GOPATH"/src/github.com/hyperledger/fabric
+}
+
+build() {
+ export GOPATH="$PWD"/.gopath
+ cd "$GOPATH"/src/github.com/hyperledger/fabric
+ make release/linux-amd64
+}
+
+package() {
+ cd $srcdir/${_pkgname}-$pkgver
+ install -Dm 644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE
+ install -Dm 644 -t "$pkgdir/usr/share/doc/$pkgname" README.md
+ cp -r release/linux-amd64/bin "$pkgdir/usr"
+}
+
+md5sums=('a3b3b80224c88fe984207e6321ccdb04')