summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302018-01-29 17:07:12 +0100
committerM0Rf302018-01-29 17:07:12 +0100
commit7c44fe5912447f02210bf8a45ebd168c466bb73e (patch)
treec9029493c393594b03795aa874ee5262759bca22
downloadaur-7c44fe5912447f02210bf8a45ebd168c466bb73e.tar.gz
hyperledger-indy-anoncreds: first commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD21
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5b03ff5d0f3b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = hyperledger-indy-anoncreds
+ pkgdesc = A python implementation of the anonymous credentials ideas developed by IBM Research
+ pkgver = 1.0.11
+ pkgrel = 1
+ url = https://github.com/hyperledger/indy-anoncreds
+ arch = i686
+ arch = x86_64
+ groups = hyperledger-indy
+ license = APACHE
+ makedepends = python
+ depends = python
+ source = https://github.com/hyperledger/indy-anoncreds/archive/1.0.11-stable.tar.gz
+ md5sums = 107b9e81283bb1af5b734422a71277cc
+
+pkgname = hyperledger-indy-anoncreds
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..91388ed26d8f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: robertfoster
+
+_pkgname=indy-anoncreds
+pkgname=hyperledger-${_pkgname}
+pkgver=1.0.11
+pkgrel=1
+pkgdesc="A python implementation of the anonymous credentials ideas developed by IBM Research"
+arch=(i686 x86_64)
+url="https://github.com/hyperledger/${_pkgname}"
+license=('APACHE')
+groups=('hyperledger-indy')
+depends=('python')
+makedepends=('python')
+source=("https://github.com/hyperledger/${_pkgname}/archive/$pkgver-stable.tar.gz")
+
+package() {
+ cd $srcdir/${_pkgname}-$pkgver-stable
+ python setup.py install -O1 --root="$pkgdir"
+}
+
+md5sums=('107b9e81283bb1af5b734422a71277cc')