summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Heinrich2020-08-25 20:40:05 +0000
committerJonas Heinrich2020-08-25 20:40:05 +0000
commitc47608b9422ccf7072feb87f859ba7c862fb5b5a (patch)
tree8242a92f7077924194db1a98d3679edcac46cbad
downloadaur-c47608b9422ccf7072feb87f859ba7c862fb5b5a.tar.gz
first commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9d78c28e63e4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = hyperpotamus
+ pkgdesc = YAML/JSON automation scripting for web requests
+ pkgver = 0.37.3
+ pkgrel = 1
+ url = https://github.com/pmarkert/hyperpotamus
+ arch = x86_64
+ license = MIT
+ makedepends = npm
+ depends = nodejs
+ source = hyperpotamus-0.37.3.tar.gz::https://github.com/pmarkert/hyperpotamus/archive/v0.37.3.tar.gz
+ sha512sums = b8d1b48e78518bcf2fa1027e53e94c5be6576aa1dee999fc38ffc2c722ab9abd4f67353982ba676bcf57c460ed074629015f9c560243a408e958d8887a5a1700
+
+pkgname = hyperpotamus
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd348dfc1119
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Jonas Heinrich <onny@project-insanity.org>
+# Contributor: Jonas Heinrich <onny@project-insanity.org>
+
+pkgname=hyperpotamus
+pkgver=0.37.3
+pkgrel=1
+pkgdesc="YAML/JSON automation scripting for web requests"
+arch=('x86_64')
+url="https://github.com/pmarkert/hyperpotamus"
+license=('MIT')
+makedepends=('npm')
+depends=('nodejs')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/pmarkert/hyperpotamus/archive/v${pkgver}.tar.gz")
+sha512sums=('b8d1b48e78518bcf2fa1027e53e94c5be6576aa1dee999fc38ffc2c722ab9abd4f67353982ba676bcf57c460ed074629015f9c560243a408e958d8887a5a1700')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ npm i
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -d "${pkgdir}/usr/lib"
+ install -d "${pkgdir}/usr/bin"
+ cp -r cli docs examples hdb.js hyperpotamus.js lib node_modules "${pkgdir}/usr/lib/"
+ echo -e '#!/usr/bin/bash\nnode /usr/lib/hyperpotamus/hyperpotamus.js "$@"' > "${pkgdir}/usr/bin/hyperpotamus"
+ chmod +x "${pkgdir}/usr/bin/hyperpotamus"
+}
+