summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjlaehne2019-11-14 15:30:18 +0100
committerjlaehne2019-11-14 15:30:18 +0100
commit992fb492adf9d1c2f962a3076cc628d834808c99 (patch)
tree13e120ed3511ab996df2a3ab281e6028cab24ed0
downloadaur-992fb492adf9d1c2f962a3076cc628d834808c99.tar.gz
Provides hyperspy-link-traits 1.0.2
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..621aedb5563e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = hyperspy-link-traits
+ pkgdesc = A fork to traitlets' link and dlink to link traits in addition to traitlets.
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://github.com/hyperspy/link_traits
+ arch = any
+ license = BSD-3-Clause
+ makedepends = python-setuptools
+ depends = python-traits
+ provides = hyperspy-link-traits
+ conflicts = hyperspy-link-traits
+ source = https://github.com/hyperspy/link_traits/archive/v1.0.2.zip
+ sha256sums = 9a7886baa676eaf99e47448dd50cb8b15dffef81df0cdf42fb23c272be9183da
+
+pkgname = hyperspy-link-traits
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a31ed3f19ac7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Contributor: Jonas Lähnemann <jonas at pdi-berlin dot de>
+# Maintainer: Jonas Lähnemann <jonas at pdi-berlin dot de>
+pkgname=hyperspy-link-traits
+pkgshort=link_traits
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="A fork to traitlets' link and dlink to link traits in addition to traitlets."
+arch=('any')
+url="https://github.com/hyperspy/link_traits"
+license=('BSD-3-Clause')
+
+depends=('python-traits')
+
+#optdepends=()
+
+makedepends=('python-setuptools')
+
+provides=('hyperspy-link-traits')
+conflicts=('hyperspy-link-traits')
+
+source=(https://github.com/hyperspy/link_traits/archive/v$pkgver.zip)
+sha256sums=('9a7886baa676eaf99e47448dd50cb8b15dffef81df0cdf42fb23c272be9183da')
+
+package() {
+ cd "$srcdir/$pkgshort-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et:
+