summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author[object Object]2023-09-08 10:59:52 +0300
committer[object Object]2023-09-08 10:59:52 +0300
commit58126ec96bb4d852a506f0d6124c260c7ef27dae (patch)
tree303bd0fc6903694f81e37344e93f08974a2b743b
parente8af988d98c8bce344bd7de1d8a7401647d3993c (diff)
downloadaur-58126ec96bb4d852a506f0d6124c260c7ef27dae.tar.gz
delete polkit
-rw-r--r--02-allow-colord.rules12
-rw-r--r--45-allow-colord.pkla1
-rw-r--r--PKGBUILD32
-rw-r--r--README.md4
-rw-r--r--hyperv-enhanced-session.service (renamed from hv-enhanced-session.service)2
-rw-r--r--xdrp-sesman20
6 files changed, 29 insertions, 42 deletions
diff --git a/02-allow-colord.rules b/02-allow-colord.rules
deleted file mode 100644
index 34a35e3caffd..000000000000
--- a/02-allow-colord.rules
+++ /dev/null
@@ -1,12 +0,0 @@
-polkit.addRule(function(action, subject) {
- if ((action.id == "org.freedesktop.color-manager.create-device" ||
- action.id == "org.freedesktop.color-manager.modify-profile" ||
- action.id == "org.freedesktop.color-manager.delete-device" ||
- action.id == "org.freedesktop.color-manager.create-profile" ||
- action.id == "org.freedesktop.color-manager.modify-profile" ||
- action.id == "org.freedesktop.color-manager.delete-profile") &&
- subject.isInGroup("users"))
- {
- return polkit.Result.YES;
- }
-});
diff --git a/45-allow-colord.pkla b/45-allow-colord.pkla
index 3245e09828e7..a94794ad55dc 100644
--- a/45-allow-colord.pkla
+++ b/45-allow-colord.pkla
@@ -1,4 +1,3 @@
-
[Allow Colord all Users]
Identity=unix-user:*
Action=org.freedesktop.color-manager.create-device;org.freedesktop.color-manager.create-profile;org.freedesktop.color-manager.delete-device;org.freedesktop.color-manager.delete-profile;org.freedesktop.color-manager.modify-device;org.freedesktop.color-manager.modify-profile
diff --git a/PKGBUILD b/PKGBUILD
index c02292561a4b..f43f787efebe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Based on:
# https://github.com/microsoft/linux-vm-tools/blob/master/arch/install-config.sh
-pkgname="hv-enhanced-session"
+pkgname="hyperv-enhanced-session"
pkgver=0.1.0
pkgrel=1
#arch=('x86_64')
@@ -28,7 +28,6 @@ optdepends=(
source=(
'hv_sock.conf'
'blacklist-vmw_vsock_vmci_transport.conf'
- '02-allow-colord.rules'
'45-allow-colord.pkla'
'xdrp-sesman'
'Xwrapper.config'
@@ -38,12 +37,14 @@ source=(
)
sha256sums=('d2caa377132c1ddb741a9fbd1af22c4c4610e1e4636041d938adc4dcb6e1780c'
+ 'dfdc916462b69871f606d3f35289b071d5598dd1ba9be12cd84902f963a0d43a'
'f25f22ad6dbbab522c1d44484797eedc7229f78a978cb5981421b470d4360183'
- 'ff7b380d0dcf12763ac56ea03ceb8a426a7f142d59a95b5e2848a0de501bcc27'
- '0d0307fa4081ca69637e7a21f1bd2199dfc2b480c953b0d860950098461f0652'
- 'e538852296d305729cb9025f29559410b22cbee33fbee03169979179dc1ff819'
- 'd2d679a2fe1994ea4a2cc0b2eb961217250bcddfba544f4b5c0597dd1b38a8ba'
- 'cafe12efadd031f8ab5f9647fcdd57d4065ab9e065724d75e34cd6b6e0e06143')
+ '964c78a9fe0da00cb0121fe42a93d04be71c88ec67308390be4be53b80980e92'
+ '7a0d70aa423511f13664e35b7831aab41f3d37461606f1ed14d6b0b0949a0628'
+ 'f0a32c2658bba8e91d65b2cd03eef69fd782d8b6104d3f61265cdf3d603f10cd'
+ 'dd6fb56f5c472489b1e01f49ebf581e1e7c3c6e4776ad8f3afd7a7411a0168cc'
+ '06a5b6764c2d5270926c1cc5f51f0d1b0edc5e5b1960bb540111f02f53375af6'
+ '679a2e1243106f6cf5ffc04a1ed2241167d39abe7aceec622192c5a91f41c08b')
build() {
:
@@ -56,15 +57,14 @@ prepare() {
package() {
cd "$srcdir"
- install -dm755 $pkgdir/{etc/{modules-load.d,polkit-1/localauthority/50-local.d,pam.d,X11},usr/lib/systemd/system,opt/$pkgname}
- install -Dm644 hv_sock.conf blacklist-vmw_vsock_vmci_transport.conf -t $pkgdir/etc/modules-load.d
- #install -Dm644 02-allow-colord.rules -t $pkgdir/etc/polkit-1
- install -Dm644 45-allow-colord.pkla -t $pkgdir/etc/polkit-1/localauthority/50-local.d
- install -Dm644 xdrp-sesman -t $pkgdir/etc/pam.d
- install -Dm644 Xwrapper.config -t $pkgdir/etc/X11
- install -Dm644 "$pkgname.service" -t $pkgdir/usr/lib/systemd/system
- install -Dm644 README.md -t $pkgdir/opt/$pkgname
- install -Dm755 configure-rdp.sh -t $pkgdir/opt/$pkgname
+ install -dm755 "$pkgdir"/{etc/{modules-load.d,polkit-1/localauthority/50-local.d,pam.d,X11},usr/lib/systemd/system,opt/$pkgname}
+ install -Dm644 hv_sock.conf blacklist-vmw_vsock_vmci_transport.conf -t "$pkgdir"/etc/modules-load.d
+ install -Dm644 45-allow-colord.pkla -t "$pkgdir"/etc/polkit-1/localauthority/50-local.d
+ install -Dm644 xdrp-sesman -t "$pkgdir"/etc/pam.d
+ install -Dm644 Xwrapper.config -t "$pkgdir"/etc/X11
+ install -Dm644 "$pkgname.service" -t "$pkgdir"/usr/lib/systemd/system
+ install -Dm644 README.md -t "$pkgdir"/opt/$pkgname
+ install -Dm755 configure-rdp.sh -t "$pkgdir"/opt/$pkgname
echo "You will have to configure .xinitrc to start your windows manager, see https://wiki.archlinux.org/index.php/Xinit"
echo "Run \"sudo systemctl enable --now $pkgname\" to enable enhanced session."
diff --git a/README.md b/README.md
index 86db46596eb7..025e65f078da 100644
--- a/README.md
+++ b/README.md
@@ -6,10 +6,10 @@ AUR package that provides enhanced session support for the Hyper-V virtual machi
```bash
# install
-yay -S hv-enhanced-session
+yay -S hyperv-enhanced-session
# enable session
-sudo systemctl enable --now hv-enhanced-session
+sudo systemctl enable --now hyperv-enhanced-session
# xrdp reads .xinitrc
echo "/usr/lib/plasma-dbus-run-session-if-needed startplasma-x11" > ~/.xinitrc
diff --git a/hv-enhanced-session.service b/hyperv-enhanced-session.service
index 64065c241bbc..ae635e957824 100644
--- a/hv-enhanced-session.service
+++ b/hyperv-enhanced-session.service
@@ -1,5 +1,5 @@
[Unit]
-Description=Enable Hyper-V enhanced Session
+Description=Enable Hyper-V Enhanced Session
After=network-online.target
Before=xrdp.service xrdp-sesman.service
Wants=network-online.target xrdp.service xrdp-sesman.service
diff --git a/xdrp-sesman b/xdrp-sesman
index 6253462c1c83..38d4a401c97a 100644
--- a/xdrp-sesman
+++ b/xdrp-sesman
@@ -1,15 +1,15 @@
#%PAM-1.0
-auth include system-remote-login
--auth optional pam_gnome_keyring.so
--auth optional pam_kwallet5.so
+auth include system-remote-login
+-auth optional pam_gnome_keyring.so
+-auth optional pam_kwallet5.so
-account include system-remote-login
+account include system-remote-login
-password include system-remote-login
--password optional pam_gnome_keyring.so use_authtok
+password include system-remote-login
+-password optional pam_gnome_keyring.so use_authtok
-session optional pam_keyinit.so force revoke
-session include system-remote-login
--session optional pam_gnome_keyring.so auto_start
--session optional pam_kwallet5.so auto_start
+session optional pam_keyinit.so force revoke
+session include system-remote-login
+-session optional pam_gnome_keyring.so auto_start
+-session optional pam_kwallet5.so auto_start