summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMitsuru Takigahira2017-04-11 20:04:18 +0900
committerMitsuru Takigahira2017-04-11 20:04:18 +0900
commit3564cd18c46b9e4e1dfafb37ae0cf9181d0013d4 (patch)
treeb23b5d42f6a6edfe9833f8985fb6ae9e76e8cb0d
downloadaur-3564cd18c46b9e4e1dfafb37ae0cf9181d0013d4.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD34
-rw-r--r--hypervfcopyd.service10
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..faca26a8637b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = hypervfcopyd
+ pkgdesc = Hyper-V File Copy Daemon for Arch Linux
+ pkgver = 4.10.1
+ pkgrel = 1
+ url = https://www.kernel.org
+ arch = x86_64
+ license = GPLv3
+ source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.10.1.tar.gz
+ source = hypervfcopyd.service
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = hypervfcopyd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..feabf13cdf83
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Mitsuru Takigahira <mysticdoll@mysticdoll.com>
+pkgname=hypervfcopyd
+pkgver=4.10.1
+pkgrel=1
+pkgdesc="Hyper-V File Copy Daemon for Arch Linux"
+url='https://www.kernel.org'
+arch=('x86_64')
+license=('GPLv3')
+depends=()
+optdepends=()
+makedepends=()
+conflicts=()
+replaces=()
+backup=()
+source=("https://www.kernel.org/pub/linux/kernel/v4.x/linux-${pkgver}.tar.gz"
+ "hypervfcopyd.service"
+ )
+install=''
+md5sums=('SKIP'
+ 'SKIP'
+ )
+
+prepare() {
+ tar xvf ${srcdir}/linux-${pkgver}.tar.gz linux-${pkgver}/tools/hv/hv_fcopy_daemon.c
+}
+
+build() {
+ gcc ${srcdir}/linux-${pkgver}/tools/hv/hv_fcopy_daemon.c -o ${srcdir}/hypervfcopyd
+}
+
+package() {
+ install -Dm 755 ${srcdir}/hypervfcopyd ${pkgdir}/usr/local/bin/hypervfcopyd
+ install -Dm 755 ${srcdir}/hypervfcopyd.service ${pkgdir}/usr/lib/systemd/system/hypervfcopyd.service
+}
diff --git a/hypervfcopyd.service b/hypervfcopyd.service
new file mode 100644
index 000000000000..4bb7506adbae
--- /dev/null
+++ b/hypervfcopyd.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Hyper-V FIle Copy daemon
+ConditionalVirtualization=microsoft
+
+[Service]
+Type=simple
+ExecStart=/usr/local/bin/hypervfcopyd -n
+
+[Install]
+WantedBy=multi-user.target