summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMitsuru Takigahira2017-04-05 17:48:06 +0900
committerMitsuru Takigahira2017-04-05 17:48:06 +0900
commit342d9f17246fa148d77b3decc0111257423697d8 (patch)
tree67d30885aa7b497a4acf5b9dd70b9dd2fc97746f
downloadaur-342d9f17246fa148d77b3decc0111257423697d8.tar.gz
initail commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD34
-rw-r--r--hypervkvpd.service10
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..854d42647896
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = hypervkvpd
+ pkgdesc = Hyper-V KVP Daemon for Arch Linux
+ pkgver = 4.10.1
+ pkgrel = 1
+ url = https://www.kernel.org
+ arch = x86_64
+ license = GPLv3
+ source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.10.1.tar.gz
+ source = hypervkvpd.service
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = hypervkvpd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0e221d6d6c2e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Mitsuru Takigahira <mysticdoll@mysticdoll.com>
+pkgname=hypervkvpd
+pkgver=4.10.1
+pkgrel=1
+pkgdesc="Hyper-V KVP Daemon for Arch Linux"
+url='https://www.kernel.org'
+arch=('x86_64')
+license=('GPLv3')
+depends=()
+optdepends=()
+makedepends=()
+conflicts=()
+replaces=()
+backup=()
+source=("https://www.kernel.org/pub/linux/kernel/v4.x/linux-${pkgver}.tar.gz"
+ "hypervkvpd.service"
+ )
+install=''
+md5sums=('SKIP'
+ 'SKIP'
+ )
+
+prepare() {
+ tar xvf ${srcdir}/linux-${pkgver}.tar.gz linux-${pkgver}/tools/hv/hv_kvp_daemon.c
+}
+
+build() {
+ gcc ${srcdir}/linux-${pkgver}/tools/hv/hv_kvp_daemon.c -o ${srcdir}/hypervkvpd
+}
+
+package() {
+ install -Dm 755 ${srcdir}/hypervkvpd ${pkgdir}/usr/local/bin/hypervkvpd
+ install -Dm 755 ${srcdir}/hypervkvpd.service ${pkgdir}/usr/lib/systemd/system/hypervkvpd.service
+}
diff --git a/hypervkvpd.service b/hypervkvpd.service
new file mode 100644
index 000000000000..f0c68e270a1c
--- /dev/null
+++ b/hypervkvpd.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Hyper-V KVP daemon
+ConditionalVirtualization=microsoft
+
+[Service]
+Type=simple
+ExecStart=/usr/local/bin/hypervkvpd -n
+
+[Install]
+WantedBy=multi-user.target