summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMitsuru Takigahira2017-04-11 19:47:46 +0900
committerMitsuru Takigahira2017-04-11 19:52:50 +0900
commite542032b96acbb59a42b6e5cc6bc0e4bde1c3082 (patch)
treecbbb0379fc86f7263a2aa964dab6d210dc3ae867
downloadaur-e542032b96acbb59a42b6e5cc6bc0e4bde1c3082.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD34
-rw-r--r--hypervvssd.service10
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..698d10c07009
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = hypervvssd
+ pkgdesc = Hyper-V VSS Daemon for Arch Linux
+ pkgver = 4.10.1
+ pkgrel = 1
+ url = https://www.kernel.org
+ arch = x86_64
+ license = GPLv3
+ source = https://www.kernel.org/pub/linux/kernel/v4.x/linux-4.10.1.tar.gz
+ source = hypervvssd.service
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = hypervvssd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..88395d62b86c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Mitsuru Takigahira <mysticdoll@mysticdoll.com>
+pkgname=hypervvssd
+pkgver=4.10.1
+pkgrel=1
+pkgdesc="Hyper-V VSS Daemon for Arch Linux"
+url='https://www.kernel.org'
+arch=('x86_64')
+license=('GPLv3')
+depends=()
+optdepends=()
+makedepends=()
+conflicts=()
+replaces=()
+backup=()
+source=("https://www.kernel.org/pub/linux/kernel/v4.x/linux-${pkgver}.tar.gz"
+ "hypervvssd.service"
+ )
+install=''
+md5sums=('SKIP'
+ 'SKIP'
+ )
+
+prepare() {
+ tar xvf ${srcdir}/linux-${pkgver}.tar.gz linux-${pkgver}/tools/hv/hv_vss_daemon.c
+}
+
+build() {
+ gcc ${srcdir}/linux-${pkgver}/tools/hv/hv_vss_daemon.c -o ${srcdir}/hypervvssd
+}
+
+package() {
+ install -Dm 755 ${srcdir}/hypervvssd ${pkgdir}/usr/local/bin/hypervvssd
+ install -Dm 755 ${srcdir}/hypervvssd.service ${pkgdir}/usr/lib/systemd/system/hypervvssd.service
+}
diff --git a/hypervvssd.service b/hypervvssd.service
new file mode 100644
index 000000000000..8abda6fc9abd
--- /dev/null
+++ b/hypervvssd.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Hyper-V VSS daemon
+ConditionalVirtualization=microsoft
+
+[Service]
+Type=simple
+ExecStart=/usr/local/bin/hypervvssd -n
+
+[Install]
+WantedBy=multi-user.target