summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJorge Barroso2015-06-15 21:31:30 +0200
committerJorge Barroso2015-06-15 21:31:30 +0200
commit8e0686de36a0112e4687f81fa5340d3ca5fd2787 (patch)
tree4271f25cc1de2c1c0ad902890e13c6adc86f9e11
downloadaur-hyphen-ca.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD40
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8af8c9e10b7c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = hyphen-ca
+ pkgdesc = Catalan hyphenation rules
+ pkgver = 1.2
+ pkgrel = 1
+ url = http://riuraueditors.cat/web/content/12-eines
+ arch = any
+ license = GPLv3
+ optdepends = hyphen: offers hyphenation library functions
+ source = http://riuraueditors.cat/particio_de_mots/hyph_ca_ES.dic
+ sha512sums = c86482576fd93ae5c91d47201af872f996fd8013d0f1c6242aa8843958b6ead63d90ff203ba52cfd4ed25da32d3cf48eea6690f0d3b7e2de0c20f2f2ef0fd465
+
+pkgname = hyphen-ca
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..989766b0c525
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: jpatufet <jpatufet86@gmail.com>
+
+pkgname=hyphen-ca
+pkgver=1.2
+pkgrel=1
+pkgdesc="Catalan hyphenation rules"
+arch=(any)
+url="http://riuraueditors.cat/web/content/12-eines"
+license=('GPLv3')
+optdepends=('hyphen: offers hyphenation library functions')
+source=('http://riuraueditors.cat/particio_de_mots/hyph_ca_ES.dic')
+sha512sums=('c86482576fd93ae5c91d47201af872f996fd8013d0f1c6242aa8843958b6ead63d90ff203ba52cfd4ed25da32d3cf48eea6690f0d3b7e2de0c20f2f2ef0fd465')
+
+
+package(){
+
+ #copy hypen
+ cd "${srcdir}"
+ install -dm755 "${pkgdir}"/usr/share/hyphen
+ cp -p hyph_ca_ES.dic "${pkgdir}"/usr/share/hyphen/hyph_ca_ES.dic
+
+ #alias hyphen - comment/delete if you don't want all these alias
+ pushd "${pkgdir}"/usr/share/hyphen/
+ ca_ES_alias="ca_AD ca_FR ca_IT"
+ for lang in ${ca_ES_alias}; do
+ ln -s hyph_ca_ES.dic hyph_${lang}.dic
+ done
+ popd
+
+ #myspell symlinks
+ install -dm755 "${pkgdir}"/usr/share/myspell/dicts
+ pushd "${pkgdir}"/usr/share/myspell/dicts
+ for file in "${pkgdir}"/usr/share/hyphen/*; do
+ ln -sv /usr/share/hyphen/"$(basename "${file}")" .
+ done
+ popd
+
+ #docs
+ #install -dm755 "${pkgdir}"/usr/share/doc/"${pkgname}"
+}