summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam Burgos2023-02-08 21:07:00 -0600
committerSam Burgos2023-02-08 21:07:00 -0600
commit1027077d53af8f273a59f1798ebd469fa0eda6b3 (patch)
tree695bb3755bf0c32d7c424ec6c12f6ad9bd9f00f7
parentec8d4498120db9a3370fa79277777f309d5be84a (diff)
downloadaur-1027077d53af8f273a59f1798ebd469fa0eda6b3.tar.gz
adopting package and updating to version 3.2
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD49
2 files changed, 29 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4fe6312f1f6d..3346150476af 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,22 @@
pkgbase = hypnotix
- pkgdesc = An IPTV streaming application
- pkgver = 2.9
+ pkgdesc = An IPTV streaming application with support for live TV, movies and series.
+ pkgver = 3.2
pkgrel = 1
url = https://github.com/linuxmint/hypnotix
arch = any
license = GPL3
depends = dconf
depends = hicolor-icon-theme
+ depends = mpv
depends = python-cairo
depends = python-gobject
depends = python-imdbpy
depends = python-requests
depends = python-setproctitle
depends = python-unidecode
- depends = mpv
depends = xapp
optdepends = yt-dlp: YouTube channel support
- source = hypnotix-2.9.tar.gz::https://github.com/linuxmint/hypnotix/archive/2.9.tar.gz
- b2sums = edf3f86a6d7b3536575bb02c566ba845cdd4bc4a0745a0c331f570c1f3ce734dafeca6306c70926e88323c6fc5fd28ea7de35229997ecdcd4bbb27c48bce851f
+ source = hypnotix-3.2.tar.gz::https://github.com/linuxmint/hypnotix/archive/refs/tags/3.2.tar.gz
+ sha256sums = c69906318dfbfd10df055d085afbe271f2e89372faa4c47a649b4827b3a7903c
pkgname = hypnotix
diff --git a/PKGBUILD b/PKGBUILD
index 99445175c97e..1bf5494b3d65 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,39 @@
-# Maintainer: Jonathon Fernyhough <jonathon+m2x@dev>
+# Maintainer: Sam Burgos <santiago.burgos1089@gmail.com>
+# Contributor: Jonathon Fernyhough <jonathon+m2x@dev>
# Contributor: Leo <olorin12+gmail+com>
pkgname=hypnotix
-pkgver=2.9
+pkgver=3.2
pkgrel=1
-pkgdesc="An IPTV streaming application"
-arch=(any)
+pkgdesc="An IPTV streaming application with support for live TV, movies and series."
+arch=('any')
url="https://github.com/linuxmint/hypnotix"
-license=(GPL3)
-depends=(dconf hicolor-icon-theme python-cairo python-gobject python-imdbpy python-requests python-setproctitle python-unidecode mpv xapp)
+license=('GPL3')
+depends=('dconf' 'hicolor-icon-theme' 'mpv' 'python-cairo' 'python-gobject'
+ 'python-imdbpy' 'python-requests' 'python-setproctitle' 'python-unidecode'
+ 'xapp')
optdepends=('yt-dlp: YouTube channel support')
-source=($pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz)
-b2sums=('edf3f86a6d7b3536575bb02c566ba845cdd4bc4a0745a0c331f570c1f3ce734dafeca6306c70926e88323c6fc5fd28ea7de35229997ecdcd4bbb27c48bce851f')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=('c69906318dfbfd10df055d085afbe271f2e89372faa4c47a649b4827b3a7903c')
prepare() {
- cd $pkgname-$pkgver
- sed -i "s/__DEB_VERSION__/$pkgver/g" usr/lib/hypnotix/hypnotix.py
+ cd "$pkgname-$pkgver"
+
+ # Set version in About dialog
+ sed -i "s/__DEB_VERSION__/${pkgver//+*/}/g" "usr/lib/$pkgname/$pkgname.py"
+
+ # Fix license path
+ sed -i 's|common-licenses/GPL|licenses/common/GPL/license.txt|g' \
+ "usr/lib/$pkgname/$pkgname.py"
}
build() {
- cd $pkgname-$pkgver
- make
+ cd "$pkgname-$pkgver"
+ make
}
package() {
- cd $pkgname-$pkgver
- install -D -t "$pkgdir"/usr/bin usr/bin/hypnotix
- install -D -t "$pkgdir"/usr/lib/hypnotix usr/lib/hypnotix/{common,hypnotix}.py
- install -Dm644 -t "$pkgdir"/usr/lib/hypnotix usr/lib/hypnotix/{mpv,xtream}.py
- install -Dm644 -t "$pkgdir"/usr/share/applications usr/share/applications/hypnotix.desktop
- install -Dm644 -t "$pkgdir"/usr/share/glib-2.0/schemas usr/share/glib-2.0/schemas/org.x.hypnotix.gschema.xml
- install -Dm644 -t "$pkgdir"/usr/share/hypnotix usr/share/hypnotix/*.{css,png,ui}
- install -Dm644 -t "$pkgdir"/usr/share/hypnotix/pictures usr/share/hypnotix/pictures/*.svg
- install -Dm644 -t "$pkgdir"/usr/share/hypnotix/pictures/badges usr/share/hypnotix/pictures/badges/*
- install -Dm644 -t "$pkgdir"/usr/share/icons/hicolor/scalable/apps usr/share/icons/hicolor/scalable/apps/hypnotix.svg
-
- # Translations
- cp -a usr/share/locale "$pkgdir"/usr/share/locale
+ cd "$pkgname-$pkgver"
+ cp -r usr/ "$pkgdir/"
}
+