summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathon Fernyhough2020-12-01 14:22:34 +0000
committerJonathon Fernyhough2020-12-01 14:22:34 +0000
commit684fd7a3610aa772645ac3c1e0cabf4826f8e5b0 (patch)
treed64b00adeecbb413c21e5c11267f7fef52a25e7a
parent78916815c3aa8e1df3ef345840d7f823c449a261 (diff)
downloadaur-684fd7a3610aa772645ac3c1e0cabf4826f8e5b0.tar.gz
Upstream 1.1
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD24
2 files changed, 18 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 39d74b288042..c2da66f06717 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,18 @@
pkgbase = hypnotix
pkgdesc = An IPTV app
- pkgver = 1.0.0
- pkgrel = 3
+ pkgver = 1.1
+ pkgrel = 1
url = https://github.com/linuxmint/hypnotix
arch = any
- license = unknown
+ license = GPL3
depends = dconf
depends = hicolor-icon-theme
- depends = lua51
depends = python-requests
depends = python-setproctitle
depends = mpv
depends = xapp
- source = https://github.com/linuxmint/hypnotix/archive/5687e0e6db8069b02cbca8140f69aa8201999324.tar.gz
- b2sums = fb2e9a576ff57227f9877374d0ba3ad16935a0af06d9c750cbe6b5703a1455ccfac750578808ce418e16c2204c41323323ea811bf1cf09574e7622703419e19a
+ source = https://github.com/linuxmint/hypnotix/archive/1.1.tar.gz
+ b2sums = 6d15118cd9342a2d007a5eb06512aa2adb449f1f6c5499cdde93f847a35f671d1d1bedafeaf4b1d5589ee736e96d9a75bb85d88c014460168a2ff45a6a9248ea
pkgname = hypnotix
diff --git a/PKGBUILD b/PKGBUILD
index 858939217631..e95d18fc298b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,30 @@
# Maintainer: Jonathon Fernyhough <jonathon+m2x@dev>
pkgname=hypnotix
-pkgver=1.0.0
-pkgrel=3
+pkgver=1.1
+pkgrel=1
pkgdesc="An IPTV app"
arch=(any)
url="https://github.com/linuxmint/hypnotix"
-license=(unknown)
-depends=(dconf hicolor-icon-theme lua51 python-requests python-setproctitle mpv xapp)
-_commit=5687e0e6db8069b02cbca8140f69aa8201999324
-source=($url/archive/$_commit.tar.gz)
-b2sums=('fb2e9a576ff57227f9877374d0ba3ad16935a0af06d9c750cbe6b5703a1455ccfac750578808ce418e16c2204c41323323ea811bf1cf09574e7622703419e19a')
+license=(GPL3)
+depends=(dconf hicolor-icon-theme python-requests python-setproctitle mpv xapp)
+source=($url/archive/$pkgver.tar.gz)
+b2sums=('6d15118cd9342a2d007a5eb06512aa2adb449f1f6c5499cdde93f847a35f671d1d1bedafeaf4b1d5589ee736e96d9a75bb85d88c014460168a2ff45a6a9248ea')
build() {
- cd $pkgname-$_commit
+ cd $pkgname-$pkgver
make
}
package() {
- cd $pkgname-$_commit
+ cd $pkgname-$pkgver
install -D -t "$pkgdir"/usr/bin usr/bin/hypnotix
- install -D -t "$pkgdir"/usr/lib/hypnotix usr/lib/hypnotix/{common,hypnotix,mpv}.py
+ install -D -t "$pkgdir"/usr/lib/hypnotix usr/lib/hypnotix/{common,hypnotix}.py
+ install -Dm644 -t "$pkgdir"/usr/lib/hypnotix usr/lib/hypnotix/mpv.py
install -Dm644 -t "$pkgdir"/usr/share/applications usr/share/applications/hypnotix.desktop
install -Dm644 -t "$pkgdir"/usr/share/glib-2.0/schemas usr/share/glib-2.0/schemas/org.x.hypnotix.gschema.xml
- install -Dm644 -t "$pkgdir"/usr/share/hypnotix usr/share/hypnotix/{hypnotix,shortcuts}.ui
+ install -Dm644 -t "$pkgdir"/usr/share/hypnotix usr/share/hypnotix/*.{css,png,ui}
+ install -Dm644 -t "$pkgdir"/usr/share/hypnotix/pictures usr/share/hypnotix/pictures/*.svg
+ install -Dm644 -t "$pkgdir"/usr/share/hypnotix/pictures/badges usr/share/hypnotix/pictures/badges/*
install -Dm644 -t "$pkgdir"/usr/share/icons/hicolor/scalable/apps usr/share/icons/hicolor/scalable/apps/hypnotix.svg
}