summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathon Fernyhough2020-11-20 01:35:24 +0000
committerJonathon Fernyhough2020-11-20 01:35:24 +0000
commitf6dc4b65ade29c6e42a5bf211eaaf19e29c4ffbd (patch)
tree5789e85ef82f98a5b561a37b5ddc4b0b70ff60d9
parent5f4e4ec547df961de640709f37149083e69ccf2c (diff)
downloadaur-f6dc4b65ade29c6e42a5bf211eaaf19e29c4ffbd.tar.gz
Update for 'second batch of features'
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 915b4f93c7cc..f9aeae840770 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hypnotix-git
pkgdesc = An IPTV app
- pkgver = r7.440acc1
+ pkgver = r18.2b0cc8e
pkgrel = 1
url = https://github.com/linuxmint/hypnotix
arch = any
@@ -9,6 +9,7 @@ pkgbase = hypnotix-git
depends = dconf
depends = hicolor-icon-theme
depends = lua51
+ depends = python-imdbpy
depends = python-requests
depends = python-setproctitle
depends = mpv
diff --git a/PKGBUILD b/PKGBUILD
index c63f75a21f7e..420c7a567bba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Jonathon Fernyhough <jonathon+m2x@dev>
pkgname=hypnotix-git
-pkgver=r7.440acc1
+pkgver=r18.2b0cc8e
pkgrel=1
pkgdesc="An IPTV app"
arch=(any)
url="https://github.com/linuxmint/hypnotix"
license=(unknown)
-depends=(dconf hicolor-icon-theme lua51 python-requests python-setproctitle mpv xapp)
+depends=(dconf hicolor-icon-theme lua51 python-imdbpy python-requests python-setproctitle mpv xapp)
makedepends=(git)
provides=(hypnotix)
conflicts=(hypnotix)
@@ -30,9 +30,12 @@ build() {
package() {
cd ${pkgname/-git}
install -D -t "$pkgdir"/usr/bin usr/bin/hypnotix
- install -D -t "$pkgdir"/usr/lib/hypnotix usr/lib/hypnotix/{common,hypnotix,mpv}.py
+ install -D -t "$pkgdir"/usr/lib/hypnotix usr/lib/hypnotix/{common,hypnotix}.py
+ install -Dm644 -t "$pkgdir"/usr/lib/hypnotix usr/lib/hypnotix/mpv.py
install -Dm644 -t "$pkgdir"/usr/share/applications usr/share/applications/hypnotix.desktop
install -Dm644 -t "$pkgdir"/usr/share/glib-2.0/schemas usr/share/glib-2.0/schemas/org.x.hypnotix.gschema.xml
- install -Dm644 -t "$pkgdir"/usr/share/hypnotix usr/share/hypnotix/*
+ install -Dm644 -t "$pkgdir"/usr/share/hypnotix usr/share/hypnotix/*.{css,png,ui}
+ install -Dm644 -t "$pkgdir"/usr/share/hypnotix/pictures usr/share/hypnotix/pictures/*.svg
+ install -Dm644 -t "$pkgdir"/usr/share/hypnotix/pictures/badges usr/share/hypnotix/pictures/badges/*
install -Dm644 -t "$pkgdir"/usr/share/icons/hicolor/scalable/apps usr/share/icons/hicolor/scalable/apps/hypnotix.svg
}