summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJordan Day2021-12-27 08:22:42 -0600
committerJordan Day2021-12-27 08:22:42 -0600
commit41b61efb14bddc045ad253a804760f1de11f5631 (patch)
tree77aa7c01d44b8cd395f658eea5aa4a828008bebf
downloadaur-41b61efb14bddc045ad253a804760f1de11f5631.tar.gz
Initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD30
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4f60fec02340
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = hypr-git
+ pkgdesc = Hypr is a Linux tiling window manager for Xorg. It's written in XCB with modern C++ and aims to provide easily readable and expandable code.
+ pkgver = 0.0
+ pkgrel = 1
+ url = https://github.com/vaxerski/Hypr
+ arch = x86_64
+ license = BSD
+ depends = cairo
+ depends = gdb
+ depends = ninja
+ depends = gcc
+ depends = cmake
+ depends = libxcb
+ depends = xcb-proto
+ depends = xcb-util
+ depends = xcb-util-cursor
+ depends = xcb-util-keysyms
+ depends = xcb-util-wm
+ depends = gtkmm
+ depends = gtk4
+ depends = gtkmm3
+ source = hypr-git::git+https://github.com/vaxerski/Hypr
+ sha256sums = SKIP
+
+pkgname = hypr-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..de97f4a0bc97
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Jordan Day < jordanday444 at gmail dot com >
+
+pkgname=hypr-git
+pkgver=0.0
+pkgrel=1
+pkgdesc="Hypr is a Linux tiling window manager for Xorg. It's written in XCB with modern C++ and aims to provide easily readable and expandable code."
+arch=('x86_64')
+url="https://github.com/vaxerski/Hypr"
+license=('BSD')
+depends=('cairo' 'gdb' 'ninja' 'gcc' 'cmake' 'libxcb' 'xcb-proto' 'xcb-util' 'xcb-util-cursor' 'xcb-util-keysyms' 'xcb-util-wm' 'gtkmm' 'gtk4' 'gtkmm3')
+source=("$pkgname::git+https://github.com/vaxerski/Hypr")
+sha256sums=('SKIP')
+
+build() {
+ cd $srcdir/$pkgname
+
+ make clear
+ make release
+}
+
+package() {
+ cd $srcdir/$pkgname
+
+ mkdir -p "${pkgdir}/usr/bin/"
+ install -D "build/Hypr" "${pkgdir}/usr/bin"
+
+ mkdir -p "${pkgdir}/usr/share/xsessions"
+ install -D "example/hypr.desktop" "${pkgdir}/usr/share/xsessions"
+}
+