summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoralba4k2024-03-07 19:45:28 +0100
committeralba4k2024-03-07 19:45:28 +0100
commit650199c8b86d9ae5b5442f5114353d1732d76071 (patch)
tree15f8db6dedac3b9523caf30903f75d97862f80d7
downloadaur-650199c8b86d9ae5b5442f5114353d1732d76071.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD37
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..17be393e3738
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = hyprcursor-git
+ pkgdesc = The hyprland cursor format, library and utilities
+ pkgver = 0.1.0.r18.aa954a2
+ pkgrel = 1
+ url = https://github.com/hyprwm/hyprcursor
+ arch = any
+ license = BSD
+ makedepends = git
+ makedepends = cmake
+ makedepends = gcc
+ makedepends = gdb
+ depends = hyprlang>=0.4.2
+ depends = cairo
+ depends = libzip
+ provides = hyprcursor
+ conflicts = hyprcursor
+ source = hyprcursor::git+https://github.com/hyprwm/hyprcursor.git
+ sha256sums = SKIP
+
+pkgname = hyprcursor-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c3c43ec01fbf
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+hyprcursor*
+pkg
+src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..67a391cd54ff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: alba4k <blaskoazzolaaaron@gmail.com>
+
+_pkgname="hyprcursor"
+pkgname="${_pkgname}-git"
+pkgver=0.1.0.r18.aa954a2
+pkgrel=1
+pkgdesc="The hyprland cursor format, library and utilities"
+arch=(any)
+url="https://github.com/hyprwm/hyprcursor"
+license=('BSD')
+depends=('hyprlang>=0.4.2' 'cairo' 'libzip')
+makedepends=('git' 'cmake' 'gcc' 'gdb')
+source=("${_pkgname}::git+https://github.com/hyprwm/hyprcursor.git")
+conflicts=("${_pkgname}")
+provides=("${_pkgname}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${_pkgname}
+ printf "0.1.0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ # git describe --long --tags --abbrev=8 --exclude='*[a-zA-Z][a-zA-Z]*' \
+ # | sed -E 's/^[^0-9]*//;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ cmake --no-warn-unused-cli -DCMAKE_BUILD_TYPE:STRING=Release -DCMAKE_INSTALL_PREFIX:PATH=/usr -S . -B ./build
+ cmake --build ./build --config Release --target all
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ DESTDIR="${pkgdir}" cmake --install build
+
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+