summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkRHYME72024-03-20 01:09:51 +0800
committerkRHYME72024-03-20 01:09:51 +0800
commit72e7b1c706d5a498cfb9d039b101eb833af5663f (patch)
tree3988755ddf23b3c0e9977ec976b28a5dd60e75b6
parent7fce348cb0cc591944d6a87e3f0f7edd93bc4a9e (diff)
downloadaur-72e7b1c706d5a498cfb9d039b101eb833af5663f.tar.gz
update
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD26
2 files changed, 9 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0063c3e82a3a..ce4c2e766c24 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = hyprdots-ctl-git
pkgdesc = CLI for Hyprdots Configurations ++ Hidden Gems
pkgver = v0.4.0.r39.g38d5c70
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/kRHYME7/Hyprdots-ctl
arch = x86_64
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index ba3351aac4b9..8eb8273f05a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,27 @@
pkgname=hyprdots-ctl-git
pkgver=v0.4.0.r39.g38d5c70
-pkgrel=1
+pkgrel=2
pkgdesc="CLI for Hyprdots Configurations ++ Hidden Gems"
arch=('x86_64')
url="https://github.com/kRHYME7/Hyprdots-ctl"
license=('GPL3')
depends=( 'fzf' 'tree' 'ttf-jetbrains-mono-nerd' )
makedepends=('git' 'make' 'curl' 'base-devel')
+conflicts=("hyprdots-ctl")
source=("git+https://github.com/kRHYME7/Hyprdots-ctl.git")
md5sums=('SKIP')
-conflicts=("hyprdots-ctl")
-
-# pkgver() {
-# cd "$srcdir/Hyprdots-ctl" || return
-# git fetch --tags
-# git describe --long --tags --always | sed 's/-/./g' # Replace hyphens with dots to conform to versioning standards
-# }
-
-# pkgver() {
-# cd "$srcdir/Hyprdots-ctl" || return
-# git fetch --tags
-# # Use git describe with a fallback to the commit hash if no tags are found
-# local version=$(git describe --tags --always --dirty 2>/dev/null)
-# # Replace hyphens with dots to conform to versioning standards
-# echo "$version" | sed 's/-/./g'
+# pkgver() {
+# git -C "${srcdir}/Hyprdots-ctl" describe --long --tags --always | sed 's/\([^-]*-g[0-9a-f]*\)/r\1/;s/[-+]/./g'
# }
pkgver() {
- git -C "${srcdir}/Hyprdots-ctl" describe --long --tags --always | sed 's/\([^-]*-g[0-9a-f]*\)/r\1/;s/[-+]/./g'
+ cd "${srcdir}/Hyprdots-ctl" || return
+ git fetch --tags
+ local version=$(git describe --long --tags --always | sed 's/\([^-]*-g[0-9a-f]*\)/r\1/;s/[-+]/./g')
+ echo "$version"
}
-
package() {
cd "${srcdir}/Hyprdots-ctl" || return
make DESTDIR="$pkgdir" clean all