summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Bainesly2024-02-27 01:13:21 -0500
committerRichard Bainesly2024-02-27 01:13:21 -0500
commit5cf7bcea7fdaf339d4d3c8de69e6332be5d4460f (patch)
treef9d1440443f8ead0e7027efd3f450d197e3746c4
parentff289f79d468080262b8324a42162fcecf155cc6 (diff)
downloadaur-5cf7bcea7fdaf339d4d3c8de69e6332be5d4460f.tar.gz
multiple changes
- remove ASAN_OPTIONS from patch - add .install file for note
-rw-r--r--.SRCINFO1
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD5
-rw-r--r--envs.patch6
-rw-r--r--note.install4
5 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0264e1a2d0e2..021fb9c17bd8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,6 +3,7 @@ pkgbase = hyprland-asan-git
pkgver = 0.35.0.r104.bc3f5b94
pkgrel = 1
url = https://github.com/hyprwm/Hyprland
+ install = note.install
arch = x86_64
arch = aarch64
license = BSD
diff --git a/.gitignore b/.gitignore
index c38e1f645d3b..0c09a4562a05 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,3 +3,4 @@
!/.SRCINFO
!/PKGBUILD
!/envs.patch
+!/note.install
diff --git a/PKGBUILD b/PKGBUILD
index 3ac5254e028c..646474a244a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -68,6 +68,7 @@ b2sums=(
'SKIP'
'SKIP'
)
+install=note.install
pick_mr() {
git pull origin pull/$1/head --no-edit
@@ -133,8 +134,4 @@ package() {
# license
install -Dm0644 -t "$pkgdir/usr/share/licenses/${pkgname}" LICENSE
}
-
-post_install() {
- note "When starting Hyprland with this package, remember to use '-c ~/.config/hyprland.conf' if you need to load your main config."
-}
# vi: et ts=2 sw=2
diff --git a/envs.patch b/envs.patch
index a75429522016..a7319f61240a 100644
--- a/envs.patch
+++ b/envs.patch
@@ -1,13 +1,13 @@
diff --git a/src/main.cpp b/src/main.cpp
-index e1f43ad0..ef2b74be 100644
+index e1f43ad0..0e716007 100644
--- a/src/main.cpp
+++ b/src/main.cpp
-@@ -34,6 +34,8 @@ int main(int argc, char** argv) {
+@@ -34,6 +34,7 @@ int main(int argc, char** argv) {
setenv("_JAVA_AWT_WM_NONREPARENTING", "1", 1);
setenv("MOZ_ENABLE_WAYLAND", "1", 1);
setenv("XDG_CURRENT_DESKTOP", "Hyprland", 1);
-+ setenv("ASAN_OPTIONS", "detect_odr_violation=0,log_path=asan.log", 1);
+ setenv("LD_PRELOAD", "/usr/lib/libasan.so.8.0.0", 1);
// parse some args
std::string configPath;
+
diff --git a/note.install b/note.install
new file mode 100644
index 000000000000..13a8268dc892
--- /dev/null
+++ b/note.install
@@ -0,0 +1,4 @@
+post_install() {
+ echo 'To enable ASan logs, start Hyprland like this: `ASAN_OPTIONS="detect_odr_violation=0,log_path=asan.log" Hyprland -c ~/.config/hypr/hyprland.conf`'
+ echo 'Then just reproduce your crashes as usual. The logs will be placed in the directory you started Hyprland in.'
+}