summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFederico Maria Morrone2024-03-19 03:37:25 +0100
committerFederico Maria Morrone2024-03-19 03:37:25 +0100
commit82c380f9df69a32fb620e8dee1ea6fe794646e88 (patch)
tree69107f9a5fc8a0b638bca5586e279312e038e33a
parent378f8d80671053261f862a3c80ed6fe0212f423b (diff)
downloadaur-82c380f9df69a32fb620e8dee1ea6fe794646e88.tar.gz
Improve packaging
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD27
2 files changed, 32 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cbe13368fa1e..9542afec4067 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hyprland-cmake-git
pkgdesc = a highly customizable dynamic tiling Wayland compositor that doesn't sacrifice on its looks.
- pkgver = 0.36.0.r116.ga958884b
+ pkgver = 0.37.1.r15.g7283dde8
pkgrel = 1
url = https://github.com/hyprwm/Hyprland
arch = x86_64
@@ -70,10 +70,17 @@ pkgbase = hyprland-cmake-git
depends = xorg-xwayland
optdepends = cmake: to build and install plugins using hyprpm
optdepends = meson: to build and install plugins using hyprpm
- provides = hyprland=0.36.0
+ provides = hyprland=0.37.1
conflicts = hyprland
- conflicts = hyprland-git
source = git+https://github.com/hyprwm/Hyprland.git
+ source = git+https://gitlab.freedesktop.org/wlroots/wlroots.git
+ source = git+https://github.com/hyprwm/hyprland-protocols
+ source = git+https://github.com/canihavesomecoffee/udis86
+ source = git+https://github.com/wolfpld/tracy
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
b2sums = SKIP
pkgname = hyprland-cmake-git
diff --git a/PKGBUILD b/PKGBUILD
index 4b45221330b5..f68547f86873 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Federico Maria Morrone <aur at morrone dot dev>
pkgname=hyprland-cmake-git
-pkgver=0.36.0.r116.ga958884b
+pkgver=0.37.1.r15.g7283dde8
pkgrel=1
pkgdesc="a highly customizable dynamic tiling Wayland compositor that doesn't sacrifice on its looks."
arch=(x86_64 aarch64)
@@ -57,14 +57,31 @@ optdepends=('cmake: to build and install plugins using hyprpm'
'meson: to build and install plugins using hyprpm')
provides=("hyprland=${pkgver%%.r*}")
-conflicts=(hyprland hyprland-git)
-source=("git+https://github.com/hyprwm/Hyprland.git")
+conflicts=(hyprland)
+source=(
+ "git+https://github.com/hyprwm/Hyprland.git"
+ "git+https://gitlab.freedesktop.org/wlroots/wlroots.git"
+ "git+https://github.com/hyprwm/hyprland-protocols"
+ "git+https://github.com/canihavesomecoffee/udis86"
+ "git+https://github.com/wolfpld/tracy"
+)
-b2sums=("SKIP")
+b2sums=(
+ "SKIP"
+ "SKIP"
+ "SKIP"
+ "SKIP"
+ "SKIP"
+)
prepare() {
cd Hyprland
- git submodule update --init --recursive
+ git submodule init
+ git config submodule.wlroots.url "$srcdir/wlroots"
+ git config submodule.subprojects/hyprland-protocols.url "$srcdir/hyprland-protocols"
+ git config submodule.subprojects/udis86.url "$srcdir/udis86"
+ git config submodule.subprojects/tracy.url "$srcdir/tracy"
+ git -c protocol.file.allow=always submodule update
sed -i -e '/^release:/{n;s/-D/-DCMAKE_SKIP_RPATH=ON -D/}' Makefile
}