summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormemchr2024-02-02 17:06:04 +0000
committermemchr2024-02-02 17:06:22 +0000
commit0658cd66f49fe73b9710cb5e840c57d8dacd4283 (patch)
tree8a338f894ad0120b603f29668bdb4c71b645e071
parente350edb6af69cec61eda3507564661ca063ba442 (diff)
downloadaur-0658cd66f49fe73b9710cb5e840c57d8dacd4283.tar.gz
remove meson patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
-rw-r--r--wlroots-meson-build.patch45
3 files changed, 7 insertions, 53 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ef800c75b59..719c2ea8b190 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hyprland-git
pkgdesc = A dynamic tiling Wayland compositor based on wlroots that doesn't sacrifice on its looks.
- pkgver = 0.31.0.r7.a0b675ec
+ pkgver = 0.34.0.r95.cf1886ca
pkgrel = 1
url = https://github.com/hyprwm/Hyprland
arch = x86_64
@@ -48,7 +48,7 @@ pkgbase = hyprland-git
depends = xorg-xinput
depends = xorg-xwayland
depends = libdisplay-info.so
- provides = hyprland=0.31.0
+ provides = hyprland=0.34.0
conflicts = hyprland
source = git+https://github.com/hyprwm/Hyprland.git
source = git+https://gitlab.freedesktop.org/wlroots/wlroots.git
diff --git a/PKGBUILD b/PKGBUILD
index 0ff1d38e9862..668780fbbd17 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -63,14 +63,13 @@ source=(
"git+https://github.com/hyprwm/hyprland-protocols.git"
"git+https://github.com/canihavesomecoffee/udis86.git"
"git+https://github.com/wolfpld/tracy.git"
- "wlroots-meson-build.patch")
+)
b2sums=(
'SKIP'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP'
)
pick_mr() {
@@ -92,7 +91,7 @@ prepare() {
# Pick pull requests from github using `pick_mr <pull request number>`.
git -C subprojects/wlroots reset --hard
- patch -d subprojects/wlroots -Np1 < ../wlroots-meson-build.patch
+ sed -E -i -e "s/(soversion = .*$)/soversion = 13032/g" subprojects/wlroots/meson.build
}
pkgver() {
@@ -114,7 +113,6 @@ build() {
-D xwayland=enabled \
-D systemd=enabled
- ln -sf wlroots build/subprojects/wlroots/include/wlr
meson compile -C build
}
@@ -124,13 +122,14 @@ package() {
meson install -C build \
--destdir "$pkgdir" \
--skip-subprojects hyprland-protocols
+ mv "$pkgdir/usr/include/wlr" "$pkgdir/usr/include/hyprland/wlroots"
- rm -rf "$pkgdir/usr/include/hyprland/wlroots/wlr"
- ln -sf . "$pkgdir/usr/include/hyprland/wlroots/wlr"
# resolve conflicts with system wlr
rm -f "$pkgdir/usr/lib/libwlroots.so"
rm -rf "$pkgdir/usr/lib/pkgconfig"
+
# FIXME: remove after xdg-desktop-portal-hyprland disowns hyprland-portals.conf
+
rm -rf "$pkgdir/usr/share/xdg-desktop-portal"
# license
diff --git a/wlroots-meson-build.patch b/wlroots-meson-build.patch
deleted file mode 100644
index a184eb774c68..000000000000
--- a/wlroots-meson-build.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-diff --git a/include/meson.build b/include/meson.build
-index e669800..687786b 100644
---- a/include/meson.build
-+++ b/include/meson.build
-@@ -1,4 +1,5 @@
--subdir('wlr')
-+run_command('ln', '-sf', join_paths(meson.project_source_root(), 'include', 'wlr'), join_paths(meson.project_source_root(), 'include', 'wlroots'), check: true)
-+subdir('wlroots')
-
- exclude_files = ['meson.build', 'config.h.in', 'version.h.in']
- if not features.get('drm-backend')
-@@ -24,8 +25,8 @@ if not features.get('session')
- exclude_files += 'backend/session.h'
- endif
-
--install_subdir('wlr',
-- install_dir: get_option('includedir'),
-+install_subdir('wlroots',
-+ install_dir: join_paths(get_option('includedir'), 'hyprland'),
- exclude_files: exclude_files,
- )
-
-diff --git a/include/wlr/meson.build b/include/wlr/meson.build
-index f7ca413..0a86d54 100644
---- a/include/wlr/meson.build
-+++ b/include/wlr/meson.build
-@@ -22,4 +22,4 @@ ver_h = configure_file(
- configuration: version_data,
- )
-
--install_headers(conf_h, ver_h, subdir: 'wlr')
-+install_headers(conf_h, ver_h, subdir: join_paths('hyprland', 'wlroots'))
-diff --git a/meson.build b/meson.build
-index 29b103a..0b6e5a4 100644
---- a/meson.build
-+++ b/meson.build
-@@ -15,7 +15,7 @@ project(
- version_major = version.split('.')[0]
- version_minor = version.split('.')[1]
- assert(version_major == '0')
--soversion = version_minor.to_int() - 5
-+soversion = 13032
-
- little_endian = target_machine.endian() == 'little'
- big_endian = target_machine.endian() == 'big'