summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormemchr2023-10-16 23:04:37 +0000
committermemchr2023-10-16 23:04:37 +0000
commit383b3c346d13c350953893cd70c6837933046740 (patch)
tree913d4d5ff4383ba6b1d1c4c3ab9013a893a12f90
parentb6ce2acc68f08df33ad4d64c589c16cfa38149fa (diff)
downloadaur-383b3c346d13c350953893cd70c6837933046740.tar.gz
fix(meson): do not use --auto-features=enable
-rw-r--r--PKGBUILD11
1 files changed, 10 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f4e6704513ff..1ef5ba693347 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -94,7 +94,16 @@ pkgver() {
build() {
cd Hyprland
- arch-meson build --buildtype=release -Db_pch=false -Ddefault_library=shared
+ meson setup build \
+ --prefix /usr \
+ --libexecdir lib \
+ --sbindir bin \
+ --buildtype release \
+ --wrap-mode nodownload \
+ -D b_lto=true \
+ -D b_pie=true \
+ -D xwayland=enabled
+
ln -sf wlroots build/subprojects/wlroots/include/wlr
meson compile -C build
}