summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormemchr2023-09-17 11:25:51 +0000
committermemchr2023-09-17 11:25:51 +0000
commit4c450495cb049461e4da80638cb2409b14ac49af (patch)
treed5625fc84c0d927b84a18ad4505651f8747baaa2
parent8d6a6fc5a7e9192db2c5323033ab614399bb6afd (diff)
downloadaur-4c450495cb049461e4da80638cb2409b14ac49af.tar.gz
add pick_mr helper for merging pull requests.
-rw-r--r--PKGBUILD11
1 files changed, 11 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3b02a458751f..6c84d42b5d6e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -65,6 +65,10 @@ b2sums=('SKIP'
'SKIP'
'SKIP')
+pick_mr() {
+ git pull origin pull/$1/head --no-edit
+}
+
prepare() {
cd Hyprland
git submodule init
@@ -74,6 +78,12 @@ prepare() {
git config submodule.subprojects/tracy.url "$srcdir/tracy"
git -c protocol.file.allow=always submodule update
+ if [[ -z "$(git config --get user.name)" ]]; then
+ git config user.name local && git config user.email '<>' && git config commit.gpgsign false
+ fi
+
+ # Pick pull requests from github using `pick_mr <pull request number>`.
+
make fixwlr
sed -i '/^release:/{n;s/-D/-DCMAKE_SKIP_RPATH=ON -D/}' Makefile
# respect build flags to allow full RELRO
@@ -127,3 +137,4 @@ package() {
install -Dm0644 -t "$pkgdir/usr/share/licenses/${pkgname}" LICENSE
install -Dm0755 -t "$pkgdir/usr/lib" "$srcdir/tmpwlr/lib/libwlroots.so.12032"
}
+# vi: et ts=2 sw=2