summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormemchr2023-10-16 23:10:01 +0000
committermemchr2023-10-16 23:10:01 +0000
commit60170496cddec57196b3c43bae51512e91cd28db (patch)
tree098f3124bc39c1c13b13a5d8ca49a2cfc2b39e87
parent383b3c346d13c350953893cd70c6837933046740 (diff)
downloadaur-60170496cddec57196b3c43bae51512e91cd28db.tar.gz
add default_library=shared
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1ef5ba693347..d3abaa230c37 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -102,6 +102,7 @@ build() {
--wrap-mode nodownload \
-D b_lto=true \
-D b_pie=true \
+ -D default_library=shared \
-D xwayland=enabled
ln -sf wlroots build/subprojects/wlroots/include/wlr
@@ -116,8 +117,8 @@ package() {
rm -rf "$pkgdir/usr/include/hyprland/wlroots/wlr"
ln -sf . "$pkgdir/usr/include/hyprland/wlroots/wlr"
# resolve conflicts with system wlr
- rm "$pkgdir/usr/lib/libwlroots.so"
- rm "$pkgdir/usr/lib/pkgconfig/wlroots.pc"
+ rm -f "$pkgdir/usr/lib/libwlroots.so"
+ rm -f "$pkgdir/usr/lib/pkgconfig/wlroots.pc"
# resolve conflicts with xdg-desktop-portal-hyprland from repo
rm -rf "$pkgdir/usr/share/xdg-desktop-portal"
# FIXME: meson.build shall install version.h