summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoréclairevoyant2023-07-08 03:08:05 -0400
committeréclairevoyant2023-07-08 03:08:05 -0400
commit95846115a4500d82b59ac6fc2edba322bbf886d8 (patch)
tree4471238bc7c9d069ac892adc26f2a1a6d910df50
parent815e924a534547ec5cec5b91995bb2c12ec074a8 (diff)
downloadaur-95846115a4500d82b59ac6fc2edba322bbf886d8.tar.gz
hyprland-git: fix pkgver(), licenses folder
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD29
3 files changed, 25 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b8e4b0c52b71..bbb6718f4a1b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = hyprland-git
pkgdesc = A dynamic tiling Wayland compositor based on wlroots that doesn't sacrifice on its looks.
- pkgver = r3043.f49af187
- pkgrel = 2
+ pkgver = 0.26.0.r96.f49af187
+ pkgrel = 1
url = https://github.com/hyprwm/Hyprland
arch = x86_64
arch = aarch64
@@ -55,9 +55,9 @@ pkgbase = hyprland-git
source = git+https://gitlab.freedesktop.org/wlroots/wlroots.git
source = git+https://github.com/hyprwm/hyprland-protocols.git
source = git+https://github.com/canihavesomecoffee/udis86.git
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
+ b2sums = SKIP
pkgname = hyprland-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..713f6f80aff8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/*
+!/.gitignore
+!/.SRCINFO
+!/PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index 5fc18a2d9393..4adc8e8a4e77 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,10 @@
-# Maintainer: ThatOneCalculator <kainoa@t1c.dev>
+# Maintainer: FabioLolix
+# Maintainer: éclairevoyant
+# Contributor: ThatOneCalculator <kainoa at t1c dot dev>
pkgname=hyprland-git
-pkgver=r3043.f49af187
-pkgrel=2
+pkgver=0.26.0.r96.f49af187
+pkgrel=1
pkgdesc="A dynamic tiling Wayland compositor based on wlroots that doesn't sacrifice on its looks."
arch=(x86_64 aarch64)
url="https://github.com/hyprwm/Hyprland"
@@ -50,21 +52,16 @@ makedepends=(cmake
ninja
vulkan-headers
xorgproto)
-provides=(hyprland)
+provides=("hyprland=${pkgver%%.r*}")
conflicts=(hyprland)
source=("git+https://github.com/hyprwm/Hyprland.git"
"git+https://gitlab.freedesktop.org/wlroots/wlroots.git"
"git+https://github.com/hyprwm/hyprland-protocols.git"
"git+https://github.com/canihavesomecoffee/udis86.git")
-sha256sums=('SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP')
-
-pkgver() {
- cd Hyprland
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
+b2sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
prepare() {
cd Hyprland
@@ -80,6 +77,10 @@ prepare() {
sed -i '/CXX/ s|)|) $(CXXFLAGS)|;/CXX/ s|$| $(LDFLAGS)|;' hyprctl/Makefile
}
+pkgver() {
+ git -C Hyprland describe --long --tags | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g'
+}
+
build() {
cd Hyprland
pushd subprojects/wlroots
@@ -120,6 +121,6 @@ package() {
install -Dm0644 -t "$pkgdir/usr/share/hyprland" assets/*.png
install -Dm0644 -t "$pkgdir/usr/share/wayland-sessions" "example/hyprland.desktop"
install -Dm0644 -t "$pkgdir/usr/share/hyprland" "example/hyprland.conf"
- install -Dm0644 -t "$pkgdir/usr/share/licenses/${pkgname}" LICENSE
+ install -Dm0644 -t "$pkgdir/usr/share/licenses/hyprland" LICENSE
install -Dm0755 -t "$pkgdir/usr/lib" "$srcdir/tmpwlr/lib/libwlroots.so.12032"
}