summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormemchr2023-10-18 22:43:43 +0000
committermemchr2023-10-18 22:43:43 +0000
commitbba92f28068e6c5e0088b13872361b2a3ff19b45 (patch)
treed5c354bdd353162f3bc097d7eaf881bc12070c3a
parent1f5451947573597384ea0b126575854bc0719331 (diff)
downloadaur-bba92f28068e6c5e0088b13872361b2a3ff19b45.tar.gz
skip install hyprland-protocols
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c777be8125c0..d8633f3115d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -120,14 +120,16 @@ build() {
package() {
cd Hyprland
- meson install -C build --destdir "$pkgdir"
+ meson install -C build \
+ --destdir "$pkgdir" \
+ --skip-subprojects hyprland-protocols
rm -rf "$pkgdir/usr/include/hyprland/wlroots/wlr"
ln -sf . "$pkgdir/usr/include/hyprland/wlroots/wlr"
# resolve conflicts with system wlr
rm -f "$pkgdir/usr/lib/libwlroots.so"
- rm -f "$pkgdir/usr/lib/pkgconfig/wlroots.pc"
- # resolve conflicts with xdg-desktop-portal-hyprland from repo
+ rm -rf "$pkgdir/usr/lib/pkgconfig"
+ # FIXME: remove after xdg-desktop-portal-hyprland disowns hyprland-portals.conf
rm -rf "$pkgdir/usr/share/xdg-desktop-portal"
# FIXME: meson.build shall install version.h
install -Dm0644 -t "$pkgdir/usr/include/hyprland/src" src/version.h