summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormemchr2024-02-02 16:48:34 +0000
committermemchr2024-02-02 16:48:34 +0000
commite350edb6af69cec61eda3507564661ca063ba442 (patch)
tree4b9212339d33a060228534b9fdd7596095cabeca
parent89be6a6bf3da8c892c9ec1eb5cae34d5812509d2 (diff)
downloadaur-e350edb6af69cec61eda3507564661ca063ba442.tar.gz
add wlroots meson patch
-rw-r--r--PKGBUILD8
-rw-r--r--wlroots-meson-build.patch45
2 files changed, 50 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cec33fd25b5b..0ff1d38e9862 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: ThatOneCalculator <kainoa at t1c dot dev>
pkgname=hyprland-git
-pkgver=0.31.0.r7.a0b675ec
+pkgver=0.34.0.r95.cf1886ca
pkgrel=1
pkgdesc="A dynamic tiling Wayland compositor based on wlroots that doesn't sacrifice on its looks."
arch=(x86_64 aarch64)
@@ -62,13 +62,15 @@ source=(
"git+https://gitlab.freedesktop.org/wlroots/wlroots.git"
"git+https://github.com/hyprwm/hyprland-protocols.git"
"git+https://github.com/canihavesomecoffee/udis86.git"
- "git+https://github.com/wolfpld/tracy.git")
+ "git+https://github.com/wolfpld/tracy.git"
+ "wlroots-meson-build.patch")
b2sums=(
'SKIP'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
)
pick_mr() {
@@ -90,7 +92,7 @@ prepare() {
# Pick pull requests from github using `pick_mr <pull request number>`.
git -C subprojects/wlroots reset --hard
- patch -d subprojects/wlroots -Np1 < subprojects/packagefiles/wlroots-meson-build.patch
+ patch -d subprojects/wlroots -Np1 < ../wlroots-meson-build.patch
}
pkgver() {
diff --git a/wlroots-meson-build.patch b/wlroots-meson-build.patch
new file mode 100644
index 000000000000..a184eb774c68
--- /dev/null
+++ b/wlroots-meson-build.patch
@@ -0,0 +1,45 @@
+diff --git a/include/meson.build b/include/meson.build
+index e669800..687786b 100644
+--- a/include/meson.build
++++ b/include/meson.build
+@@ -1,4 +1,5 @@
+-subdir('wlr')
++run_command('ln', '-sf', join_paths(meson.project_source_root(), 'include', 'wlr'), join_paths(meson.project_source_root(), 'include', 'wlroots'), check: true)
++subdir('wlroots')
+
+ exclude_files = ['meson.build', 'config.h.in', 'version.h.in']
+ if not features.get('drm-backend')
+@@ -24,8 +25,8 @@ if not features.get('session')
+ exclude_files += 'backend/session.h'
+ endif
+
+-install_subdir('wlr',
+- install_dir: get_option('includedir'),
++install_subdir('wlroots',
++ install_dir: join_paths(get_option('includedir'), 'hyprland'),
+ exclude_files: exclude_files,
+ )
+
+diff --git a/include/wlr/meson.build b/include/wlr/meson.build
+index f7ca413..0a86d54 100644
+--- a/include/wlr/meson.build
++++ b/include/wlr/meson.build
+@@ -22,4 +22,4 @@ ver_h = configure_file(
+ configuration: version_data,
+ )
+
+-install_headers(conf_h, ver_h, subdir: 'wlr')
++install_headers(conf_h, ver_h, subdir: join_paths('hyprland', 'wlroots'))
+diff --git a/meson.build b/meson.build
+index 29b103a..0b6e5a4 100644
+--- a/meson.build
++++ b/meson.build
+@@ -15,7 +15,7 @@ project(
+ version_major = version.split('.')[0]
+ version_minor = version.split('.')[1]
+ assert(version_major == '0')
+-soversion = version_minor.to_int() - 5
++soversion = 13032
+
+ little_endian = target_machine.endian() == 'little'
+ big_endian = target_machine.endian() == 'big'