summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorq234rty2023-04-29 18:04:34 +0800
committerq234rty2023-04-29 18:04:34 +0800
commit0284470ebf0e53726b0821e98a603f18ded02e60 (patch)
tree37396969294bdb26514a31dfe41efb905f8c7daf
parent013d2a8697521173eb50a561767b3b702c9434b1 (diff)
downloadaur-0284470ebf0e53726b0821e98a603f18ded02e60.tar.gz
Fix headers path
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 991160a957d3..8c90c2f821ce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hyprland-hidpi-xprop-git
pkgdesc = A dynamic tiling Wayland compositor based on wlroots that doesn't sacrifice on its looks.
- pkgver = r2838.093755d5
+ pkgver = r2840.ce6c13f8
pkgrel = 1
url = https://github.com/hyprwm/Hyprland
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 6ca35ed73fc1..37355b5f9801 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_pkgname="hyprland"
pkgname="${_pkgname}-hidpi-xprop-git"
-pkgver=r2838.093755d5
+pkgver=r2840.ce6c13f8
pkgrel=1
pkgdesc="A dynamic tiling Wayland compositor based on wlroots that doesn't sacrifice on its looks."
arch=("i686" "x86_64" "arm" "armv6h" "armv7h" "aarch64")
@@ -95,7 +95,7 @@ build() {
cd "./subprojects/wlroots/" && meson setup build/ --prefix="${srcdir}/tmpwlr" --buildtype=plain && ninja -C build/ && mkdir -p "${srcdir}/tmpwlr" && ninja -C build/ install && cd ../..
cd "./subprojects/udis86/" && cmake --no-warn-unused-cli -DCMAKE_BUILD_TYPE:STRING=None -H./ -B./build -G Ninja && cmake --build ./build --target all && cd ../..
mkdir -p build && cd build
- cmake -G Ninja -DCMAKE_BUILD_TYPE=None -DCMAKE_SKIP_RPATH=ON -DCMAKE_INSTALL_PREFIX=/usr ..
+ cmake -G Ninja -DCMAKE_BUILD_TYPE=None -DCMAKE_SKIP_RPATH=ON -DCMAKE_INSTALL_PREFIX=/usr/include/hyprland ..
ninja
cd "${srcdir}/${_pkgname}"
cd ./hyprctl && make all && cd ..
@@ -113,10 +113,10 @@ package() {
install -Dm644 subprojects/udis86/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-udis86"
install -Dm644 docs/*.1 -t "${pkgdir}/usr/share/man/man1"
install -Dm755 ../tmpwlr/lib/libwlroots.so.* -t "${pkgdir}/usr/lib"
- install -d "${pkgdir}/usr/include/hyprland/protocols"
- cp -R src ${pkgdir}/usr/include/hyprland/
- cp -R ../tmpwlr/include/* ${pkgdir}/usr/include/hyprland/
+ install -d "${pkgdir}/usr/include/hyprland/include/hyprland/protocols"
+ cp -R src ${pkgdir}/usr/include/hyprland/include/hyprland/
+ cp -R ../tmpwlr/include/* ${pkgdir}/usr/include/hyprland/include/
find ${pkgdir}/usr/include/hyprland/ -type f ! -name '*.h*' -delete
- cp protocols/*-protocol.h ${pkgdir}/usr/include/hyprland/protocols
+ cp protocols/*-protocol.h ${pkgdir}/usr/include/hyprland/include/hyprland/protocols
install -Dm644 build/hyprland.pc -t "${pkgdir}/usr/share/pkgconfig"
}