summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAleksana2022-10-24 19:26:28 +0800
committerAleksana2022-10-24 19:26:28 +0800
commit16e29c0c278a1998cd86f1dd89170343fe482afc (patch)
tree8e3abaff8a00ec113e1766bfc7562a71fb7f1df3
downloadaur-16e29c0c278a1998cd86f1dd89170343fe482afc.tar.gz
initial commit
-rw-r--r--.SRCINFO55
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD96
3 files changed, 156 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d15c8694f361
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,55 @@
+pkgbase = hyprland-hidpi-xprop-git
+ pkgdesc = A dynamic tiling Wayland compositor based on wlroots that doesn't sacrifice on its looks.
+ pkgver = r1918.1030325
+ pkgrel = 1
+ url = https://github.com/hyprwm/Hyprland
+ arch = any
+ license = BSD
+ makedepends = git
+ makedepends = cmake
+ makedepends = ninja
+ makedepends = gcc
+ makedepends = gdb
+ makedepends = meson
+ makedepends = vulkan-headers
+ makedepends = wayland-protocols
+ makedepends = xorgproto
+ depends = libxcb
+ depends = xcb-proto
+ depends = xcb-util
+ depends = xcb-util-keysyms
+ depends = libxfixes
+ depends = libx11
+ depends = libxcomposite
+ depends = xorg-xinput
+ depends = libxrender
+ depends = pixman
+ depends = wayland-protocols
+ depends = cairo
+ depends = pango
+ depends = polkit
+ depends = glslang
+ depends = libinput
+ depends = libxcb
+ depends = libxkbcommon
+ depends = opengl-driver
+ depends = pixman
+ depends = wayland
+ depends = xcb-util-errors
+ depends = xcb-util-renderutil
+ depends = xcb-util-wm
+ depends = seatd
+ depends = vulkan-icd-loader
+ depends = vulkan-validation-layers
+ depends = xorg-xwayland-hidpi-xprop
+ provides = hyprland
+ conflicts = hyprland
+ options = !makeflags
+ options = !buildflags
+ options = !strip
+ source = hyprland::git+https://github.com/hyprwm/Hyprland.git
+ source = https://gitlab.freedesktop.org/lilydjwg/wlroots/-/commit/6c5ffcd1fee9e44780a6a8792f74ecfbe24a1ca7.patch
+ sha256sums = SKIP
+ sha256sums = a37e441c309b35e5d9b5c5c637c96729c5348a523a7eaa25c6e24b1fcc3521a6
+
+pkgname = hyprland-hidpi-xprop-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..868991ba0e85
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/src
+/pkg
+/hyprland-hidpi-xprop-git*
+*pkg.tar.zst
+hyprland/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..02bd4a811ee6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,96 @@
+# Maintainer: Aleksana QwQ <me@aleksana.moe>
+# Contributor: ThatOneCalculator <kainoa@t1c.dev>
+
+_pkgname="hyprland"
+pkgname="${_pkgname}-hidpi-xprop-git"
+pkgver=r1918.1030325
+pkgrel=1
+pkgdesc="A dynamic tiling Wayland compositor based on wlroots that doesn't sacrifice on its looks."
+arch=(any)
+url="https://github.com/hyprwm/Hyprland"
+license=('BSD')
+depends=(
+ libxcb
+ xcb-proto
+ xcb-util
+ xcb-util-keysyms
+ libxfixes
+ libx11
+ libxcomposite
+ xorg-xinput
+ libxrender
+ pixman
+ wayland-protocols
+ cairo
+ pango
+ polkit
+ glslang
+ libinput
+ libxcb
+ libxkbcommon
+ opengl-driver
+ pixman
+ wayland
+ xcb-util-errors
+ xcb-util-renderutil
+ xcb-util-wm
+ seatd
+ vulkan-icd-loader
+ vulkan-validation-layers
+ xorg-xwayland-hidpi-xprop)
+makedepends=(
+ git
+ cmake
+ ninja
+ gcc
+ gdb
+ meson
+ vulkan-headers
+ wayland-protocols
+ xorgproto)
+source=("${_pkgname}::git+https://github.com/hyprwm/Hyprland.git"
+ "https://gitlab.freedesktop.org/lilydjwg/wlroots/-/commit/6c5ffcd1fee9e44780a6a8792f74ecfbe24a1ca7.patch")
+conflicts=("${_pkgname}")
+provides=(hyprland)
+sha256sums=('SKIP'
+ 'a37e441c309b35e5d9b5c5c637c96729c5348a523a7eaa25c6e24b1fcc3521a6')
+options=(!makeflags !buildflags !strip)
+
+pkgver() {
+ cd "$_pkgname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+prepare() {
+ cd "${srcdir}/${_pkgname}"
+ git submodule update --init
+
+ cd subprojects/wlroots
+ git revert -n 18595000f3a21502fd60bf213122859cc348f9af
+ patch -Np1 < "${srcdir}"/6c5ffcd1fee9e44780a6a8792f74ecfbe24a1ca7.patch
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ make fixwlr
+ cd "./subprojects/wlroots/" && meson build/ --prefix="${srcdir}/tmpwlr" --buildtype=release && ninja -C build/ && mkdir -p "${srcdir}/tmpwlr" && ninja -C build/ install && cd ../../
+ make protocols
+ make release
+ cd ./hyprctl && make all && cd ..
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ mkdir -p "${pkgdir}/usr/share/wayland-sessions"
+ mkdir -p "${pkgdir}/usr/share/hyprland"
+ install -Dm755 build/Hyprland -t "${pkgdir}/usr/bin"
+ install -Dm755 hyprctl/hyprctl -t "${pkgdir}/usr/bin"
+ install -Dm644 assets/*.png -t "${pkgdir}/usr/share/hyprland"
+ install -Dm644 example/hyprland.desktop -t "${pkgdir}/usr/share/wayland-sessions"
+ install -Dm644 example/hyprland.conf -t "${pkgdir}/usr/share/hyprland"
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${_pkgname}"
+ install -Dm755 ../tmpwlr/lib/libwlroots.so.11032 -t "${pkgdir}/usr/lib"
+}