summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorq234rty2024-01-28 13:28:19 +0800
committerq234rty2024-01-28 13:28:42 +0800
commit2532801789d1fde70c418e6ce6476e74628b85bf (patch)
treeb78097bd1468734876acd4aa8e0a9262d0452703
parent3fd3cf7c1fbdf385635a191d7b4bb03031eea4e7 (diff)
downloadaur-2532801789d1fde70c418e6ce6476e74628b85bf.tar.gz
Fix build
-rw-r--r--.SRCINFO8
-rw-r--r--0001-Revert-compositor-send-WL_SURFACE_ERROR_INVALID_SIZE.patch45
-rw-r--r--PKGBUILD8
3 files changed, 55 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 72d50f21ade0..f3e98bd2b556 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = hyprland-hidpi-xprop-git
pkgdesc = A dynamic tiling Wayland compositor based on wlroots that doesn't sacrifice on its looks.
- pkgver = 0.34.0.r48.3c964a9f
- pkgrel = 2
+ pkgver = 0.34.0.r74.df990c80
+ pkgrel = 1
url = https://github.com/hyprwm/Hyprland
arch = i686
arch = x86_64
@@ -45,13 +45,14 @@ pkgbase = hyprland-hidpi-xprop-git
depends = seatd
depends = xorg-xwayland-hidpi-xprop
depends = tomlplusplus
- provides = hyprland=0.34.0.r48.3c964a9f
+ provides = hyprland=0.34.0.r74.df990c80
conflicts = hyprland
options = debug
source = hyprland::git+https://github.com/hyprwm/Hyprland.git
source = git+https://gitlab.freedesktop.org/wlroots/wlroots.git
source = git+https://github.com/hyprwm/hyprland-protocols.git
source = git+https://github.com/canihavesomecoffee/udis86.git
+ source = 0001-Revert-compositor-send-WL_SURFACE_ERROR_INVALID_SIZE.patch
source = 0001-xwayland-support-HiDPI-scale.patch
source = 0002-Fix-configure_notify-event.patch
source = 0003-Fix-size-hints-under-Xwayland-scaling.patch
@@ -59,6 +60,7 @@ pkgbase = hyprland-hidpi-xprop-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = 7758eb3ca20b657e53b01c239c5234898342322f41af1cd9e9a8841fca2d5e2b
sha256sums = b717f2f61aeb3bf670fe60424a8cd638d51e73dc66bd84277fada289bf2330d8
sha256sums = acced048ce6359f4f9f894ee648e4c47fd5093db3fce285b60f73b9f80bb7ac9
sha256sums = 4e6b32ea58ecfd6a2cce7e5ddf09160136714de8b58e41a9919b30e06e998178
diff --git a/0001-Revert-compositor-send-WL_SURFACE_ERROR_INVALID_SIZE.patch b/0001-Revert-compositor-send-WL_SURFACE_ERROR_INVALID_SIZE.patch
new file mode 100644
index 000000000000..4ab2278b0996
--- /dev/null
+++ b/0001-Revert-compositor-send-WL_SURFACE_ERROR_INVALID_SIZE.patch
@@ -0,0 +1,45 @@
+From 8fbdf00990a7195b6fa7c338b496bc07005dd51c Mon Sep 17 00:00:00 2001
+From: q234rty <q23456yuiop@gmail.com>
+Date: Sat, 27 Jan 2024 21:06:42 +0800
+Subject: [PATCH] Revert "compositor: send WL_SURFACE_ERROR_INVALID_SIZE for
+ non-cursor surfaces"
+
+This reverts commit 18595000f3a21502fd60bf213122859cc348f9af.
+---
+ types/wlr_compositor.c | 19 +++++--------------
+ 1 file changed, 5 insertions(+), 14 deletions(-)
+
+diff --git a/types/wlr_compositor.c b/types/wlr_compositor.c
+index c5a604ac..95c23ed7 100644
+--- a/types/wlr_compositor.c
++++ b/types/wlr_compositor.c
+@@ -191,21 +191,12 @@ static void surface_finalize_pending(struct wlr_surface *surface) {
+ if (!pending->viewport.has_src &&
+ (pending->buffer_width % pending->scale != 0 ||
+ pending->buffer_height % pending->scale != 0)) {
+- // TODO: send WL_SURFACE_ERROR_INVALID_SIZE error to cursor surfaces
+- // once this issue is resolved:
++ // TODO: send WL_SURFACE_ERROR_INVALID_SIZE error once this issue is
++ // resolved:
+ // https://gitlab.freedesktop.org/wayland/wayland/-/issues/194
+- if (!surface->role
+- || strcmp(surface->role->name, "wl_pointer-cursor") == 0
+- || strcmp(surface->role->name, "wp_tablet_tool-cursor") == 0) {
+- wlr_log(WLR_DEBUG, "Client bug: submitted a buffer whose size (%dx%d) "
+- "is not divisible by scale (%d)", pending->buffer_width,
+- pending->buffer_height, pending->scale);
+- } else {
+- wlr_surface_reject_pending(surface, surface->resource,
+- WL_SURFACE_ERROR_INVALID_SIZE,
+- "Buffer size (%dx%d) is not divisible by scale (%d)",
+- pending->buffer_width, pending->buffer_height, pending->scale);
+- }
++ wlr_log(WLR_DEBUG, "Client bug: submitted a buffer whose size (%dx%d) "
++ "is not divisible by scale (%d)", pending->buffer_width,
++ pending->buffer_height, pending->scale);
+ }
+
+ if (pending->viewport.has_dst) {
+--
+2.43.0
+
diff --git a/PKGBUILD b/PKGBUILD
index 14bed95f9211..c836c68e3fe0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,8 @@
_pkgname="hyprland"
pkgname="${_pkgname}-hidpi-xprop-git"
-pkgver=0.34.0.r48.3c964a9f
-pkgrel=2
+pkgver=0.34.0.r74.df990c80
+pkgrel=1
pkgdesc="A dynamic tiling Wayland compositor based on wlroots that doesn't sacrifice on its looks."
arch=("i686" "x86_64" "arm" "armv6h" "armv7h" "aarch64")
url="https://github.com/hyprwm/Hyprland"
@@ -55,6 +55,7 @@ source=("${_pkgname}::git+https://github.com/hyprwm/Hyprland.git"
"git+https://gitlab.freedesktop.org/wlroots/wlroots.git"
"git+https://github.com/hyprwm/hyprland-protocols.git"
"git+https://github.com/canihavesomecoffee/udis86.git"
+ "0001-Revert-compositor-send-WL_SURFACE_ERROR_INVALID_SIZE.patch"
"0001-xwayland-support-HiDPI-scale.patch"
"0002-Fix-configure_notify-event.patch"
"0003-Fix-size-hints-under-Xwayland-scaling.patch")
@@ -64,6 +65,7 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ '7758eb3ca20b657e53b01c239c5234898342322f41af1cd9e9a8841fca2d5e2b'
'b717f2f61aeb3bf670fe60424a8cd638d51e73dc66bd84277fada289bf2330d8'
'acced048ce6359f4f9f894ee648e4c47fd5093db3fce285b60f73b9f80bb7ac9'
'4e6b32ea58ecfd6a2cce7e5ddf09160136714de8b58e41a9919b30e06e998178')
@@ -84,7 +86,7 @@ prepare() {
git -c protocol.file.allow=always submodule update subprojects/hyprland-protocols
git -c protocol.file.allow=always submodule update subprojects/udis86
cd subprojects/wlroots
- git revert -n 18595000f3a21502fd60bf213122859cc348f9af
+ patch -Np1 -i "${srcdir}"/0001-Revert-compositor-send-WL_SURFACE_ERROR_INVALID_SIZE.patch
patch -Np1 -i "${srcdir}"/0001-xwayland-support-HiDPI-scale.patch
patch -Np1 -i "${srcdir}"/0002-Fix-configure_notify-event.patch
patch -Np1 -i "${srcdir}"/0003-Fix-size-hints-under-Xwayland-scaling.patch