summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorq234rty2023-02-27 23:56:54 +0800
committerq234rty2023-02-27 23:57:13 +0800
commit3e6b71ab55ead07db726c220a7b8c62aa59fe31b (patch)
treee96bfede98ae2ffad768938644887c667275cae7
parent1ba59e8e81de557545b3e287cd858f3bc5d41083 (diff)
downloadaur-3e6b71ab55ead07db726c220a7b8c62aa59fe31b.tar.gz
Fix build
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 9 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7e0d2c3c75a8..f494a99e22ab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hyprland-hidpi-xprop-git
pkgdesc = A dynamic tiling Wayland compositor based on wlroots that doesn't sacrifice on its looks.
- pkgver = r2416.760b37f7
+ pkgver = r2495.3bceabe2
pkgrel = 1
url = https://github.com/hyprwm/Hyprland
arch = any
@@ -49,10 +49,12 @@ pkgbase = hyprland-hidpi-xprop-git
source = hyprland::git+https://github.com/hyprwm/Hyprland.git
source = git+https://gitlab.freedesktop.org/wlroots/wlroots.git
source = git+https://github.com/hyprwm/hyprland-protocols.git
+ source = git+https://github.com/canihavesomecoffee/udis86.git
source = https://gitlab.freedesktop.org/lilydjwg/wlroots/-/commit/6c5ffcd1fee9e44780a6a8792f74ecfbe24a1ca7.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = a37e441c309b35e5d9b5c5c637c96729c5348a523a7eaa25c6e24b1fcc3521a6
pkgname = hyprland-hidpi-xprop-git
diff --git a/PKGBUILD b/PKGBUILD
index 50af293ba097..dda325294676 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname="hyprland"
pkgname="${_pkgname}-hidpi-xprop-git"
-pkgver=r2416.760b37f7
+pkgver=r2495.3bceabe2
pkgrel=1
pkgdesc="A dynamic tiling Wayland compositor based on wlroots that doesn't sacrifice on its looks."
arch=(any)
@@ -50,12 +50,14 @@ makedepends=(
source=("${_pkgname}::git+https://github.com/hyprwm/Hyprland.git"
"git+https://gitlab.freedesktop.org/wlroots/wlroots.git"
"git+https://github.com/hyprwm/hyprland-protocols.git"
+ "git+https://github.com/canihavesomecoffee/udis86.git"
"https://gitlab.freedesktop.org/lilydjwg/wlroots/-/commit/6c5ffcd1fee9e44780a6a8792f74ecfbe24a1ca7.patch")
conflicts=("${_pkgname}")
provides=(hyprland)
sha256sums=('SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'a37e441c309b35e5d9b5c5c637c96729c5348a523a7eaa25c6e24b1fcc3521a6')
options=(!makeflags !buildflags !strip)
@@ -73,8 +75,10 @@ prepare() {
git submodule init
git config submodule.wlroots.url "${srcdir}"/wlroots
git config submodule.subprojects/hyprland-protocols.url "${srcdir}"/hyprland-protocols
+ git config submodule.subprojects/udis86.url "${srcdir}"/udis86
git -c protocol.file.allow=always submodule update subprojects/wlroots
git -c protocol.file.allow=always submodule update subprojects/hyprland-protocols
+ git -c protocol.file.allow=always submodule update subprojects/udis86
cd subprojects/wlroots
git revert -n 18595000f3a21502fd60bf213122859cc348f9af
git cherry-pick -n 03412e9aaba3f2bedacbeeef53469f13d6b6b277
@@ -85,6 +89,7 @@ build() {
cd "${srcdir}/${_pkgname}"
make fixwlr
cd "./subprojects/wlroots/" && meson build/ --prefix="${srcdir}/tmpwlr" --buildtype=release && ninja -C build/ && mkdir -p "${srcdir}/tmpwlr" && ninja -C build/ install && cd ../../
+ cd "./subprojects/udis86/" && cmake --no-warn-unused-cli -DCMAKE_BUILD_TYPE:STRING=Release -H./ -B./build -G Ninja && cmake --build ./build --config Release --target all -j$(nproc) && cd ../..
make protocols
make release
cd ./hyprctl && make all && cd ..