summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMoeta Yuko2024-06-16 15:04:34 +0800
committerMoeta Yuko2024-06-16 16:42:08 +0800
commit46d04f8e495431f35629adf92068c475de787c6a (patch)
treee2c1bffb375d967717c5c3dcd9ae199b2d765e77
parentaff597100214c948024d10866b55f49f3cd8012f (diff)
downloadaur-46d04f8e495431f35629adf92068c475de787c6a.tar.gz
Switch back to cmake
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD53
2 files changed, 31 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d94b4475fcf4..40f2662796da 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hyprland-hidpi-xprop-git
pkgdesc = A dynamic tiling Wayland compositor based on wlroots that doesn't sacrifice on its looks.
- pkgver = 0.41.0.r18.6df397be
+ pkgver = 0.41.1.r21.1f5fd7e6
pkgrel = 1
url = https://github.com/hyprwm/Hyprland
arch = i686
@@ -63,7 +63,7 @@ pkgbase = hyprland-hidpi-xprop-git
optdepends = cmake: to build and install plugins using hyprpm
optdepends = cpio: to build and install plugins using hyprpm
optdepends = meson: to build and install plugins using hyprpm
- provides = hyprland=0.41.0
+ provides = hyprland=0.41.1
conflicts = hyprland
options = debug
source = git+https://github.com/hyprwm/Hyprland.git
diff --git a/PKGBUILD b/PKGBUILD
index 6f51fdca8041..af4d881587ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,9 @@
# Contributor: Aleksana QwQ <me@aleksana.moe>
# Contributor: lilydjwg <lilydjwg@gmail.com>
-pkgname=hyprland-hidpi-xprop-git
-pkgver=0.41.0.r18.6df397be
+_pkgname=hyprland
+pkgname=$_pkgname-hidpi-xprop-git
+pkgver=0.41.1.r21.1f5fd7e6
pkgrel=1
pkgdesc="A dynamic tiling Wayland compositor based on wlroots that doesn't sacrifice on its looks."
arch=("i686" "x86_64" "arm" "armv6h" "armv7h" "aarch64")
@@ -118,31 +119,35 @@ build() {
cd Hyprland
export CXXFLAGS="-w" # suppress all compiler warnings
- meson setup build \
- --wipe \
- --prefix /usr \
- --libexecdir lib \
- --buildtype release \
- --wrap-mode nodownload \
- -D warning_level=0 \
- -D b_lto=true \
- -D b_pie=true \
- -D default_library=shared \
- -D xwayland=enabled \
- -D systemd=enabled
-
- meson compile -C build
+ mkdir -p build && cd build
+ cmake -G Ninja -DCMAKE_BUILD_TYPE=None -DCMAKE_SKIP_RPATH=ON -DCMAKE_INSTALL_PREFIX=/usr ..
+ ninja
}
package() {
cd Hyprland
-
- meson install -C build --destdir "$pkgdir"
-
- # FIXME: remove after xdg-desktop-portal-hyprland disowns hyprland-portals.conf
- rm -rf "$pkgdir/usr/share/xdg-desktop-portal"
-
- # license
- install -Dm0644 -t "$pkgdir/usr/share/licenses/${pkgname}" LICENSE
+ find src \( -name '*.h' -o -name '*.hpp' \) -exec install -Dm0644 {} "$pkgdir/usr/include/hyprland/{}" \;
+ pushd subprojects/wlroots-hyprland/include
+ find . -name '*.h' -exec install -Dm0644 {} "$pkgdir/usr/include/hyprland/wlroots-hyprland/{}" \;
+ popd
+ pushd subprojects/wlroots-hyprland/build/include
+ find . -name '*.h' -exec install -Dm0644 {} "$pkgdir/usr/include/hyprland/wlroots-hyprland/{}" \;
+ popd
+ mkdir -p "$pkgdir/usr/include/hyprland/protocols"
+ cp protocols/*.h* "$pkgdir/usr/include/hyprland/protocols"
+ install -Dm0644 -t "$pkgdir/usr/share/pkgconfig" build/hyprland.pc
+ install -Dm0644 -t "$pkgdir/usr/share/man/man1" docs/{Hyprland,hyprctl}.1
+ for cmd in hyprctl hyprpm; do
+ install -Dm0644 "$cmd/$cmd.bash" "$pkgdir/usr/share/bash-completion/completions/$cmd"
+ install -Dm0644 "$cmd/$cmd.zsh" "$pkgdir/usr/share/zsh/site-functions/_$cmd"
+ install -Dm0644 -t "$pkgdir/usr/share/fish/vendor_completions.d/" "$cmd/$cmd.fish"
+ done
+ install -Dm0755 -t "$pkgdir/usr/bin/" build/Hyprland build/hyprctl/hyprctl build/hyprpm/hyprpm
+ install -Dm0644 -t "$pkgdir/usr/share/$_pkgname/" assets/*.png
+ install -Dm0644 -t "$pkgdir/usr/share/wayland-sessions/" "example/$_pkgname.desktop"
+ install -Dm0644 -t "$pkgdir/usr/share/$_pkgname/" "example/$_pkgname.conf"
+ install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE
+ find subprojects/wlroots-hyprland/build -name 'libwlroots.so.*' -type f -execdir \
+ install -Dm0755 -t "$pkgdir/usr/lib/" {} \;
}
# vi: et ts=2 sw=2