summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorq234rty2023-04-04 22:52:53 +0800
committerq234rty2023-04-04 22:57:21 +0800
commit6266baf25fa1d93086fb1c2c75e90d942f0d4922 (patch)
tree967764696b87db3c1ebb20733406f9cf83fa6dcb
parentbfc69ee3e5db32f81a16fd0a294ca3f2950c6f6f (diff)
downloadaur-6266baf25fa1d93086fb1c2c75e90d942f0d4922.tar.gz
Revert "Fix wlroots patch"
This reverts commit bfc69ee3e5db32f81a16fd0a294ca3f2950c6f6f.
-rw-r--r--.SRCINFO6
-rw-r--r--0001-xwayland-support-HiDPI-scale.patch26
-rw-r--r--0002-Fix-configure_notify-event.patch6
-rw-r--r--PKGBUILD6
4 files changed, 22 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b57415034d30..7a095ee53795 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hyprland-hidpi-xprop-git
pkgdesc = A dynamic tiling Wayland compositor based on wlroots that doesn't sacrifice on its looks.
- pkgver = r2686.882be776
+ pkgver = r2689.6519c030
pkgrel = 1
url = https://github.com/hyprwm/Hyprland
arch = any
@@ -54,7 +54,7 @@ pkgbase = hyprland-hidpi-xprop-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 304aaf12cbd7dc198bf7e418d729b297ea61186d27c035e4a63a337399fcec76
- sha256sums = e7cf16e39db2bde4dbc9d7ec3b4753f7643b1bf198a3179e6802a9c603437fe9
+ sha256sums = e3e3dab89f6cadeb330e03921c0485b2802be6a1267747237e702cbe6d02d65f
+ sha256sums = 97105bee80596fd4aa21dde35d23847604a5b0e36c04b1679f7a2b9213774561
pkgname = hyprland-hidpi-xprop-git
diff --git a/0001-xwayland-support-HiDPI-scale.patch b/0001-xwayland-support-HiDPI-scale.patch
index a9e86fb3ac31..645986314065 100644
--- a/0001-xwayland-support-HiDPI-scale.patch
+++ b/0001-xwayland-support-HiDPI-scale.patch
@@ -1,7 +1,7 @@
-From 48f97d24d4b7f9d5fd0d4accdbaa009b365bd61b Mon Sep 17 00:00:00 2001
+From 5d04dc68d7a952c2b98cab7af60bba93bee2dec7 Mon Sep 17 00:00:00 2001
From: lilydjwg <lilydjwg@gmail.com>
Date: Wed, 17 Nov 2021 19:34:58 +0800
-Subject: [PATCH] xwayland: support HiDPI scale
+Subject: [PATCH 1/2] xwayland: support HiDPI scale
This supports the xorg-xwayland patch at https://gitlab.freedesktop.org/xorg/xserver/-/merge_requests/733
---
@@ -10,7 +10,7 @@ This supports the xorg-xwayland patch at https://gitlab.freedesktop.org/xorg/xse
2 files changed, 40 insertions(+), 13 deletions(-)
diff --git a/include/xwayland/xwm.h b/include/xwayland/xwm.h
-index c69504e8..1a332b6c 100644
+index 3d540522..33ff1478 100644
--- a/include/xwayland/xwm.h
+++ b/include/xwayland/xwm.h
@@ -88,6 +88,7 @@ enum atom_name {
@@ -21,7 +21,7 @@ index c69504e8..1a332b6c 100644
ATOM_LAST // keep last
};
-@@ -98,6 +99,7 @@ struct wlr_xwm {
+@@ -96,6 +97,7 @@ struct wlr_xwm {
struct wl_event_source *event_source;
struct wlr_seat *seat;
uint32_t ping_timeout;
@@ -30,7 +30,7 @@ index c69504e8..1a332b6c 100644
xcb_atom_t atoms[ATOM_LAST];
xcb_connection_t *xcb_conn;
diff --git a/xwayland/xwm.c b/xwayland/xwm.c
-index 5a36dc21..8449977e 100644
+index 5f857f24..4f03b07c 100644
--- a/xwayland/xwm.c
+++ b/xwayland/xwm.c
@@ -19,6 +19,14 @@
@@ -45,10 +45,10 @@ index 5a36dc21..8449977e 100644
+ return (val + xwm->scale/2) / xwm->scale;
+}
+
- const char *const atom_map[ATOM_LAST] = {
+ static const char *const atom_map[ATOM_LAST] = {
[WL_SURFACE_ID] = "WL_SURFACE_ID",
[WL_SURFACE_SERIAL] = "WL_SURFACE_SERIAL",
-@@ -90,6 +98,7 @@ const char *const atom_map[ATOM_LAST] = {
+@@ -90,6 +98,7 @@ static const char *const atom_map[ATOM_LAST] = {
[DND_ACTION_PRIVATE] = "XdndActionPrivate",
[NET_CLIENT_LIST] = "_NET_CLIENT_LIST",
[NET_CLIENT_LIST_STACKING] = "_NET_CLIENT_LIST_STACKING",
@@ -56,7 +56,7 @@ index 5a36dc21..8449977e 100644
};
#define STARTUP_INFO_REMOVE_PREFIX "remove: ID="
-@@ -968,8 +977,8 @@ static void xwm_handle_create_notify(struct wlr_xwm *xwm,
+@@ -965,8 +974,8 @@ static void xwm_handle_create_notify(struct wlr_xwm *xwm,
return;
}
@@ -67,7 +67,7 @@ index 5a36dc21..8449977e 100644
}
static void xwm_handle_destroy_notify(struct wlr_xwm *xwm,
-@@ -1000,10 +1009,10 @@ static void xwm_handle_configure_request(struct wlr_xwm *xwm,
+@@ -997,10 +1006,10 @@ static void xwm_handle_configure_request(struct wlr_xwm *xwm,
struct wlr_xwayland_surface_configure_event wlr_event = {
.surface = surface,
@@ -82,7 +82,7 @@ index 5a36dc21..8449977e 100644
.mask = mask,
};
-@@ -1018,14 +1027,14 @@ static void xwm_handle_configure_notify(struct wlr_xwm *xwm,
+@@ -1015,14 +1024,14 @@ static void xwm_handle_configure_notify(struct wlr_xwm *xwm,
}
bool geometry_changed =
@@ -103,7 +103,7 @@ index 5a36dc21..8449977e 100644
}
if (xsurface->override_redirect != ev->override_redirect) {
-@@ -1135,7 +1144,22 @@ static void xwm_handle_unmap_notify(struct wlr_xwm *xwm,
+@@ -1132,7 +1141,22 @@ static void xwm_handle_unmap_notify(struct wlr_xwm *xwm,
static void xwm_handle_property_notify(struct wlr_xwm *xwm,
xcb_property_notify_event_t *ev) {
struct wlr_xwayland_surface *xsurface = lookup_surface(xwm, ev->window);
@@ -126,7 +126,7 @@ index 5a36dc21..8449977e 100644
return;
}
-@@ -1772,7 +1796,7 @@ void wlr_xwayland_surface_configure(struct wlr_xwayland_surface *xsurface,
+@@ -1769,7 +1793,7 @@ void wlr_xwayland_surface_configure(struct wlr_xwayland_surface *xsurface,
uint32_t mask = XCB_CONFIG_WINDOW_X | XCB_CONFIG_WINDOW_Y |
XCB_CONFIG_WINDOW_WIDTH | XCB_CONFIG_WINDOW_HEIGHT |
XCB_CONFIG_WINDOW_BORDER_WIDTH;
@@ -135,7 +135,7 @@ index 5a36dc21..8449977e 100644
xcb_configure_window(xwm->xcb_conn, xsurface->window_id, mask, values);
// If the window size did not change, then we cannot rely on
-@@ -2125,6 +2149,7 @@ struct wlr_xwm *xwm_create(struct wlr_xwayland *xwayland, int wm_fd) {
+@@ -2122,6 +2146,7 @@ struct wlr_xwm *xwm_create(struct wlr_xwayland *xwayland, int wm_fd) {
wl_list_init(&xwm->pending_startup_ids);
xwm->ping_timeout = 10000;
diff --git a/0002-Fix-configure_notify-event.patch b/0002-Fix-configure_notify-event.patch
index c80f4795d8ea..4ffc0bfacb09 100644
--- a/0002-Fix-configure_notify-event.patch
+++ b/0002-Fix-configure_notify-event.patch
@@ -1,4 +1,4 @@
-From 950808724d20d8daa1e26d7a0ae322eda14cd1cc Mon Sep 17 00:00:00 2001
+From 2fbf42a76ebf3959fb95a6c0ea66a6f04b032070 Mon Sep 17 00:00:00 2001
From: q234rty <q23456yuiop@gmail.com>
Date: Tue, 21 Feb 2023 23:56:26 +0800
Subject: [PATCH 2/2] Fix configure_notify event
@@ -8,10 +8,10 @@ Subject: [PATCH 2/2] Fix configure_notify event
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/xwayland/xwm.c b/xwayland/xwm.c
-index 8449977e..2cce8a26 100644
+index 4f03b07c..f5ceedb1 100644
--- a/xwayland/xwm.c
+++ b/xwayland/xwm.c
-@@ -1809,10 +1809,10 @@ void wlr_xwayland_surface_configure(struct wlr_xwayland_surface *xsurface,
+@@ -1806,10 +1806,10 @@ void wlr_xwayland_surface_configure(struct wlr_xwayland_surface *xsurface,
.response_type = XCB_CONFIGURE_NOTIFY,
.event = xsurface->window_id,
.window = xsurface->window_id,
diff --git a/PKGBUILD b/PKGBUILD
index b574076698bb..661cfc767add 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_pkgname="hyprland"
pkgname="${_pkgname}-hidpi-xprop-git"
-pkgver=r2686.882be776
+pkgver=r2689.6519c030
pkgrel=1
pkgdesc="A dynamic tiling Wayland compositor based on wlroots that doesn't sacrifice on its looks."
arch=(any)
@@ -61,8 +61,8 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- '304aaf12cbd7dc198bf7e418d729b297ea61186d27c035e4a63a337399fcec76'
- 'e7cf16e39db2bde4dbc9d7ec3b4753f7643b1bf198a3179e6802a9c603437fe9')
+ 'e3e3dab89f6cadeb330e03921c0485b2802be6a1267747237e702cbe6d02d65f'
+ '97105bee80596fd4aa21dde35d23847604a5b0e36c04b1679f7a2b9213774561')
options=(debug)
pkgver() {