summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorq234rty2023-10-15 14:00:05 +0800
committerq234rty2023-10-15 14:00:32 +0800
commit896a977476aa74fcdbbdc44225948295a08e31a8 (patch)
tree1c535394c9777b332a7a1cd4cac81990b629f298
parent3f36daebcaa021cf3a5f207a2e48bce7dfdbf00e (diff)
downloadaur-896a977476aa74fcdbbdc44225948295a08e31a8.tar.gz
Fix build, remove vulkan deps
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD21
2 files changed, 9 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 53924cc667dc..205f2896ea75 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hyprland-hidpi-xprop-git
pkgdesc = A dynamic tiling Wayland compositor based on wlroots that doesn't sacrifice on its looks.
- pkgver = 0.28.0.r81.41d9b6f0
+ pkgver = 0.30.0.r91.261c5944
pkgrel = 1
url = https://github.com/hyprwm/Hyprland
arch = i686
@@ -15,7 +15,6 @@ pkgbase = hyprland-hidpi-xprop-git
makedepends = ninja
makedepends = gcc
makedepends = meson
- makedepends = vulkan-headers
makedepends = wayland-protocols
makedepends = xorgproto
depends = libxcb
@@ -44,9 +43,8 @@ pkgbase = hyprland-hidpi-xprop-git
depends = xcb-util-renderutil
depends = xcb-util-wm
depends = seatd
- depends = vulkan-icd-loader
depends = xorg-xwayland-hidpi-xprop
- provides = hyprland=0.28.0.r81.41d9b6f0
+ provides = hyprland=0.30.0.r91.261c5944
conflicts = hyprland
options = debug
source = hyprland::git+https://github.com/hyprwm/Hyprland.git
diff --git a/PKGBUILD b/PKGBUILD
index f80583fef0ac..08b31d3c7253 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
_pkgname="hyprland"
pkgname="${_pkgname}-hidpi-xprop-git"
-pkgver=0.28.0.r81.41d9b6f0
+pkgver=0.30.0.r91.261c5944
pkgrel=1
pkgdesc="A dynamic tiling Wayland compositor based on wlroots that doesn't sacrifice on its looks."
arch=("i686" "x86_64" "arm" "armv6h" "armv7h" "aarch64")
@@ -39,7 +39,6 @@ depends=(
xcb-util-renderutil
xcb-util-wm
seatd
- vulkan-icd-loader
xorg-xwayland-hidpi-xprop
)
makedepends=(
@@ -48,7 +47,6 @@ makedepends=(
ninja
gcc
meson
- vulkan-headers
wayland-protocols
xorgproto
)
@@ -76,6 +74,7 @@ pkgver() {
prepare() {
cd "${srcdir}/${_pkgname}"
+ sed -i 's/${BUILDTYPE_LOWER}/plain/g' CMakeLists.txt
rm -rf subprojects/wlroots subprojects/hyprland-protocols
git submodule init
git config submodule.wlroots.url "${srcdir}"/wlroots
@@ -89,27 +88,20 @@ prepare() {
patch -Np1 -i "${srcdir}"/0001-xwayland-support-HiDPI-scale.patch
patch -Np1 -i "${srcdir}"/0002-Fix-configure_notify-event.patch
patch -Np1 -i "${srcdir}"/0003-Fix-size-hints-under-Xwayland-scaling.patch
- cd "${srcdir}/${_pkgname}"
- make fixwlr
- # respect build flags to allow full RELRO
- sed -i '/CXX/ s|)|) $(CXXFLAGS)|;/CXX/ s|$| $(LDFLAGS)|;' hyprctl/Makefile
}
build() {
cd "${srcdir}/${_pkgname}"
- cd "./subprojects/wlroots/" && meson setup build/ --prefix="${srcdir}/tmpwlr" --buildtype=plain && ninja -C build/ && mkdir -p "${srcdir}/tmpwlr" && ninja -C build/ install && cd ../..
- cd "./subprojects/udis86/" && cmake --no-warn-unused-cli -DCMAKE_BUILD_TYPE:STRING=None -H./ -B./build -G Ninja && cmake --build ./build --target all && cd ../..
mkdir -p build && cd build
cmake -G Ninja -DCMAKE_BUILD_TYPE=None -DCMAKE_SKIP_RPATH=ON -DCMAKE_INSTALL_PREFIX=/usr ..
ninja
- cd "${srcdir}/${_pkgname}"
- cd ./hyprctl && make all && cd ..
}
package() {
cd "${srcdir}/${_pkgname}"
+ meson install -C subprojects/wlroots/build --destdir "${pkgdir}/tmpwlr"
install -Dm755 build/Hyprland -t "${pkgdir}/usr/bin"
- install -Dm755 hyprctl/hyprctl -t "${pkgdir}/usr/bin"
+ install -Dm755 build/hyprctl/hyprctl -t "${pkgdir}/usr/bin"
install -Dm644 assets/*.png -t "${pkgdir}/usr/share/hyprland"
install -Dm644 example/hyprland.desktop -t "${pkgdir}/usr/share/wayland-sessions"
install -Dm644 example/hyprland.conf -t "${pkgdir}/usr/share/hyprland"
@@ -117,12 +109,13 @@ package() {
install -Dm644 subprojects/wlroots/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-wlroots"
install -Dm644 subprojects/udis86/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-udis86"
install -Dm644 docs/*.1 -t "${pkgdir}/usr/share/man/man1"
- install -Dm755 ../tmpwlr/lib/libwlroots.so.* -t "${pkgdir}/usr/lib"
+ install -Dm755 ${pkgdir}/tmpwlr/usr/local/lib/libwlroots.so.* -t "${pkgdir}/usr/lib"
install -d "${pkgdir}/usr/include/hyprland/protocols"
install -d "${pkgdir}/usr/include/hyprland/wlroots"
cp -R src ${pkgdir}/usr/include/hyprland/
- cp -R ../tmpwlr/include/* ${pkgdir}/usr/include/hyprland/wlroots/
+ cp -R ${pkgdir}/tmpwlr/usr/local/include/* ${pkgdir}/usr/include/hyprland/wlroots/
find ${pkgdir}/usr/include/hyprland/ -type f ! -name '*.h*' -delete
+ rm -rf ${pkgdir}/tmpwlr
cp protocols/*-protocol.h ${pkgdir}/usr/include/hyprland/protocols
install -Dm644 build/hyprland.pc -t "${pkgdir}/usr/share/pkgconfig"
}