summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorq234rty2023-03-23 00:13:00 +0800
committerq234rty2023-03-23 00:21:01 +0800
commit9882e1953140ca61c91e741efbe2ea0e975183fe (patch)
treea79f4fb511fbb06b6de2e7aaf8c1b800aa0e528b
parent4f8809e09aefa810526d74281ce3154cdcf4b21d (diff)
downloadaur-9882e1953140ca61c91e741efbe2ea0e975183fe.tar.gz
Use optimized debug build and distro build flags
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e58d6f3cdf83..e08e934668db 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hyprland-hidpi-xprop-git
pkgdesc = A dynamic tiling Wayland compositor based on wlroots that doesn't sacrifice on its looks.
- pkgver = r2633.cb229f64
+ pkgver = r2636.a8b3be2c
pkgrel = 1
url = https://github.com/hyprwm/Hyprland
arch = any
@@ -43,9 +43,7 @@ pkgbase = hyprland-hidpi-xprop-git
depends = xorg-xwayland-hidpi-xprop
provides = hyprland
conflicts = hyprland
- options = !makeflags
- options = !buildflags
- options = !strip
+ options = debug
source = hyprland::git+https://github.com/hyprwm/Hyprland.git
source = git+https://gitlab.freedesktop.org/wlroots/wlroots.git
source = git+https://github.com/hyprwm/hyprland-protocols.git
diff --git a/PKGBUILD b/PKGBUILD
index 4556572d68f7..45ee26ca1132 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,11 @@
# Maintainer: Aleksana QwQ <me@aleksana.moe>
+# Maintainer: q234 rty <q23456yuiop at gmail dot com>
# Contributor: ThatOneCalculator <kainoa@t1c.dev>
+# Contributor: lilydjwg <lilydjwg@gmail.com>
_pkgname="hyprland"
pkgname="${_pkgname}-hidpi-xprop-git"
-pkgver=r2633.cb229f64
+pkgver=r2636.a8b3be2c
pkgrel=1
pkgdesc="A dynamic tiling Wayland compositor based on wlroots that doesn't sacrifice on its looks."
arch=(any)
@@ -61,7 +63,7 @@ sha256sums=('SKIP'
'SKIP'
'e3e3dab89f6cadeb330e03921c0485b2802be6a1267747237e702cbe6d02d65f'
'97105bee80596fd4aa21dde35d23847604a5b0e36c04b1679f7a2b9213774561')
-options=(!makeflags !buildflags !strip)
+options=(debug)
pkgver() {
cd "$_pkgname"
@@ -90,10 +92,13 @@ prepare() {
build() {
cd "${srcdir}/${_pkgname}"
make fixwlr
- cd "./subprojects/wlroots/" && meson build/ --prefix="${srcdir}/tmpwlr" --buildtype=release && ninja -C build/ && mkdir -p "${srcdir}/tmpwlr" && ninja -C build/ install && cd ../../
- cd "./subprojects/udis86/" && cmake --no-warn-unused-cli -DCMAKE_BUILD_TYPE:STRING=Release -H./ -B./build -G Ninja && cmake --build ./build --config Release --target all -j$(nproc) && cd ../..
+ cd "./subprojects/wlroots/" && meson setup build/ --prefix="${srcdir}/tmpwlr" --buildtype=plain && ninja -C build/ && mkdir -p "${srcdir}/tmpwlr" && ninja -C build/ install && cd ../..
+ cd "./subprojects/udis86/" && cmake --no-warn-unused-cli -DCMAKE_BUILD_TYPE:STRING=None -H./ -B./build -G Ninja && cmake --build ./build --target all && cd ../..
make protocols
- make release
+ mkdir -p build && cd build
+ cmake -G Ninja -DCMAKE_BUILD_TYPE=None ..
+ ninja
+ cd "${srcdir}/${_pkgname}"
cd ./hyprctl && make all && cd ..
}