summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorq234rty2022-12-14 18:31:15 +0800
committerq234rty2022-12-14 18:34:55 +0800
commitc0be55254ae54765ea0f9a6d1695738f8d00f3a3 (patch)
treec867e9326ae9b77e24d9af7dc3bf181e5e08fc73
parentc4e31fde2d2e6fc6dd45d9914a16268c13ae20a2 (diff)
downloadaur-c0be55254ae54765ea0f9a6d1695738f8d00f3a3.tar.gz
Include submodules in source()
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
2 files changed, 20 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d15c8694f361..decf2557a57c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = hyprland-hidpi-xprop-git
pkgdesc = A dynamic tiling Wayland compositor based on wlroots that doesn't sacrifice on its looks.
- pkgver = r1918.1030325
- pkgrel = 1
+ pkgver = r2198.5d66122
+ pkgrel = 2
url = https://github.com/hyprwm/Hyprland
arch = any
license = BSD
@@ -48,8 +48,12 @@ pkgbase = hyprland-hidpi-xprop-git
options = !buildflags
options = !strip
source = hyprland::git+https://github.com/hyprwm/Hyprland.git
+ source = git+https://gitlab.freedesktop.org/wlroots/wlroots.git
+ source = git+https://github.com/hyprwm/hyprland-protocols.git
source = https://gitlab.freedesktop.org/lilydjwg/wlroots/-/commit/6c5ffcd1fee9e44780a6a8792f74ecfbe24a1ca7.patch
sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = a37e441c309b35e5d9b5c5c637c96729c5348a523a7eaa25c6e24b1fcc3521a6
pkgname = hyprland-hidpi-xprop-git
diff --git a/PKGBUILD b/PKGBUILD
index aa5f3683bac7..a6d797a048a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname="hyprland"
pkgname="${_pkgname}-hidpi-xprop-git"
pkgver=r2198.5d66122
-pkgrel=1
+pkgrel=2
pkgdesc="A dynamic tiling Wayland compositor based on wlroots that doesn't sacrifice on its looks."
arch=(any)
url="https://github.com/hyprwm/Hyprland"
@@ -49,11 +49,15 @@ makedepends=(
wayland-protocols
xorgproto)
source=("${_pkgname}::git+https://github.com/hyprwm/Hyprland.git"
- "https://gitlab.freedesktop.org/lilydjwg/wlroots/-/commit/6c5ffcd1fee9e44780a6a8792f74ecfbe24a1ca7.patch")
+ "git+https://gitlab.freedesktop.org/wlroots/wlroots.git"
+ "git+https://github.com/hyprwm/hyprland-protocols.git"
+ "https://gitlab.freedesktop.org/lilydjwg/wlroots/-/commit/6c5ffcd1fee9e44780a6a8792f74ecfbe24a1ca7.patch")
conflicts=("${_pkgname}")
provides=(hyprland)
sha256sums=('SKIP'
- 'a37e441c309b35e5d9b5c5c637c96729c5348a523a7eaa25c6e24b1fcc3521a6')
+ 'SKIP'
+ 'SKIP'
+ 'a37e441c309b35e5d9b5c5c637c96729c5348a523a7eaa25c6e24b1fcc3521a6')
options=(!makeflags !buildflags !strip)
pkgver() {
@@ -66,8 +70,12 @@ pkgver() {
prepare() {
cd "${srcdir}/${_pkgname}"
- git submodule update --init
-
+ rm -rf subprojects/wlroots subprojects/hyprland-protocols
+ git submodule init
+ git config submodule.wlroots.url "${srcdir}"/wlroots
+ git config submodule.subprojects/hyprland-protocols.url "${srcdir}"/hyprland-protocols
+ git -c protocol.file.allow=always submodule update subprojects/wlroots
+ git -c protocol.file.allow=always submodule update subprojects/hyprland-protocols
cd subprojects/wlroots
git revert -n 18595000f3a21502fd60bf213122859cc348f9af
patch -Np1 < "${srcdir}"/6c5ffcd1fee9e44780a6a8792f74ecfbe24a1ca7.patch
@@ -78,7 +86,7 @@ build() {
make fixwlr
cd "./subprojects/wlroots/" && meson build/ --prefix="${srcdir}/tmpwlr" --buildtype=release && ninja -C build/ && mkdir -p "${srcdir}/tmpwlr" && ninja -C build/ install && cd ../../
make protocols
- make release
+ make release
cd ./hyprctl && make all && cd ..
}