summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorq234rty2024-04-13 11:08:30 +0800
committerq234rty2024-04-13 11:08:48 +0800
commitee9dd37fe92e8070e5f97e69a1efa5e517bdfe5c (patch)
tree290613913cc0f4d1ddd82c62d19b8116330fef3f
parentbe5d2fc55ae07e49895f45d40a25c4f4b3129a14 (diff)
downloadaur-ee9dd37fe92e8070e5f97e69a1efa5e517bdfe5c.tar.gz
Fix build
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD23
2 files changed, 17 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 94e43c18850f..d3f74bfc2b6c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hyprland-hidpi-xprop-git
pkgdesc = A dynamic tiling Wayland compositor based on wlroots that doesn't sacrifice on its looks.
- pkgver = 0.37.1.r20.05c84304
+ pkgver = 0.38.0.r105.582d6233
pkgrel = 1
url = https://github.com/hyprwm/Hyprland
arch = i686
@@ -33,6 +33,7 @@ pkgbase = hyprland-hidpi-xprop-git
depends = polkit
depends = glslang
depends = libdisplay-info
+ depends = libliftoff
depends = libinput
depends = libxcb
depends = libxkbcommon
@@ -42,16 +43,17 @@ pkgbase = hyprland-hidpi-xprop-git
depends = xcb-util-errors
depends = xcb-util-renderutil
depends = xcb-util-wm
+ depends = xcb-util-image
depends = seatd
depends = xorg-xwayland-hidpi-xprop
depends = tomlplusplus
depends = hyprlang
depends = hyprcursor
- provides = hyprland=0.37.1.r20.05c84304
+ provides = hyprland=0.38.0.r105.582d6233
conflicts = hyprland
options = debug
source = hyprland::git+https://github.com/hyprwm/Hyprland.git
- source = git+https://gitlab.freedesktop.org/wlroots/wlroots.git
+ source = git+https://github.com/hyprwm/wlroots-hyprland.git
source = git+https://github.com/hyprwm/hyprland-protocols.git
source = git+https://github.com/canihavesomecoffee/udis86.git
source = 0001-Revert-compositor-send-WL_SURFACE_ERROR_INVALID_SIZE.patch
diff --git a/PKGBUILD b/PKGBUILD
index 8085d06fb419..a1039109ea09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
_pkgname="hyprland"
pkgname="${_pkgname}-hidpi-xprop-git"
-pkgver=0.37.1.r20.05c84304
+pkgver=0.38.0.r105.582d6233
pkgrel=1
pkgdesc="A dynamic tiling Wayland compositor based on wlroots that doesn't sacrifice on its looks."
arch=("i686" "x86_64" "arm" "armv6h" "armv7h" "aarch64")
@@ -29,6 +29,7 @@ depends=(
polkit
glslang
libdisplay-info
+ libliftoff
libinput
libxcb
libxkbcommon
@@ -38,6 +39,7 @@ depends=(
xcb-util-errors
xcb-util-renderutil
xcb-util-wm
+ xcb-util-image
seatd
xorg-xwayland-hidpi-xprop
tomlplusplus
@@ -54,7 +56,7 @@ makedepends=(
xorgproto
)
source=("${_pkgname}::git+https://github.com/hyprwm/Hyprland.git"
- "git+https://gitlab.freedesktop.org/wlroots/wlroots.git"
+ "git+https://github.com/hyprwm/wlroots-hyprland.git"
"git+https://github.com/hyprwm/hyprland-protocols.git"
"git+https://github.com/canihavesomecoffee/udis86.git"
"0001-Revert-compositor-send-WL_SURFACE_ERROR_INVALID_SIZE.patch"
@@ -79,15 +81,15 @@ pkgver() {
prepare() {
cd "${srcdir}/${_pkgname}"
- rm -rf subprojects/wlroots subprojects/hyprland-protocols
+ rm -rf subprojects/wlroots-hyprland subprojects/hyprland-protocols
git submodule init
- git config submodule.wlroots.url "${srcdir}"/wlroots
+ git config submodule.subprojects/wlroots-hyprland.url "${srcdir}"/wlroots-hyprland
git config submodule.subprojects/hyprland-protocols.url "${srcdir}"/hyprland-protocols
git config submodule.subprojects/udis86.url "${srcdir}"/udis86
- git -c protocol.file.allow=always submodule update subprojects/wlroots
+ git -c protocol.file.allow=always submodule update subprojects/wlroots-hyprland
git -c protocol.file.allow=always submodule update subprojects/hyprland-protocols
git -c protocol.file.allow=always submodule update subprojects/udis86
- cd subprojects/wlroots
+ cd subprojects/wlroots-hyprland
patch -Np1 -i "${srcdir}"/0001-Revert-compositor-send-WL_SURFACE_ERROR_INVALID_SIZE.patch
patch -Np1 -i "${srcdir}"/0001-xwayland-support-HiDPI-scale.patch
patch -Np1 -i "${srcdir}"/0002-Fix-configure_notify-event.patch
@@ -103,7 +105,7 @@ build() {
package() {
cd "${srcdir}/${_pkgname}"
- meson install -C subprojects/wlroots/build --destdir "${pkgdir}/tmpwlr"
+ meson install -C subprojects/wlroots-hyprland/build --destdir "${pkgdir}/tmpwlr"
install -Dm755 build/Hyprland -t "${pkgdir}/usr/bin"
pushd "${pkgdir}/usr/bin" && ln -sf Hyprland hyprland && popd
install -Dm755 build/hyprctl/hyprctl -t "${pkgdir}/usr/bin"
@@ -112,14 +114,13 @@ package() {
install -Dm644 example/hyprland.desktop -t "${pkgdir}/usr/share/wayland-sessions"
install -Dm644 example/hyprland.conf -t "${pkgdir}/usr/share/hyprland"
install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
- install -Dm644 subprojects/wlroots/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-wlroots"
+ install -Dm644 subprojects/wlroots-hyprland/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-wlroots-hyprland"
install -Dm644 subprojects/udis86/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-udis86"
install -Dm644 docs/*.1 -t "${pkgdir}/usr/share/man/man1"
- install -Dm755 ${pkgdir}/tmpwlr/usr/local/lib/libwlroots.so.* -t "${pkgdir}/usr/lib"
install -d "${pkgdir}/usr/include/hyprland/protocols"
- install -d "${pkgdir}/usr/include/hyprland/wlroots"
+ install -d "${pkgdir}/usr/include/hyprland/wlroots-hyprland"
cp -R src ${pkgdir}/usr/include/hyprland/
- cp -R ${pkgdir}/tmpwlr/usr/local/include/* ${pkgdir}/usr/include/hyprland/wlroots/
+ cp -R ${pkgdir}/tmpwlr/usr/local/include/* ${pkgdir}/usr/include/hyprland/wlroots-hyprland/
find ${pkgdir}/usr/include/hyprland/ -type f ! -name '*.h*' -delete
rm -rf ${pkgdir}/tmpwlr
cp protocols/*-protocol.h ${pkgdir}/usr/include/hyprland/protocols