summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordasnacl2024-05-30 23:35:45 +0900
committerdasnacl2024-05-30 23:35:45 +0900
commita6580b1258356c1be73d3a14fec7a900d6bdd51e (patch)
tree11b0bddcf5a59fbc9254f04021fd0e54a3f1a5e5
parent472f2195e7721ca8c5c34bfc3f45d560bf66d77d (diff)
downloadaur-a6580b1258356c1be73d3a14fec7a900d6bdd51e.tar.gz
new dep
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
2 files changed, 7 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 76e346330d86..542ea6d18e61 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hyprland-nosystemd-git
pkgdesc = A dynamic tiling Wayland compositor based on wlroots that doesn't sacrifice on its looks. (w/o systemd)
- pkgver = 0.40.0.r145.5e6f7b1c
+ pkgver = 0.40.0.r144.a60c7283
pkgrel = 1
url = https://github.com/hyprwm/Hyprland
arch = x86_64
@@ -15,7 +15,6 @@ pkgbase = hyprland-nosystemd-git
makedepends = vulkan-headers
makedepends = pkgconf
makedepends = xorgproto
- makedepends = hyprwayland-scanner-git
depends = cairo
depends = cpio
depends = gcc-libs
@@ -24,6 +23,7 @@ pkgbase = hyprland-nosystemd-git
depends = glslang
depends = hyprlang
depends = hyprcursor
+ depends = hyprwayland-scanner
depends = libdisplay-info
depends = libdrm
depends = libglvnd
diff --git a/PKGBUILD b/PKGBUILD
index 09abf573e4e7..81cda05300c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,6 +17,7 @@ depends=(
glslang
hyprlang
hyprcursor
+ hyprwayland-scanner
libdisplay-info
libdrm
libglvnd
@@ -58,7 +59,6 @@ makedepends=(
vulkan-headers
pkgconf
xorgproto
- hyprwayland-scanner-git
)
provides=("hyprland=${pkgver%%.r*}")
conflicts=(hyprland)
@@ -80,10 +80,6 @@ pick_mr() {
git pull origin pull/$1/head --no-edit
}
-pkgver() {
- git -C Hyprland describe --long --tags | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g'
-}
-
prepare() {
cd hyprland-nosystemd-git
git submodule init
@@ -95,12 +91,15 @@ prepare() {
git -C subprojects/wlroots-hyprland reset --hard
}
+
+pkgver() {
+ git -C hyprland-nosystemd-git describe --long --tags | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g'
}
+
build() {
cd hyprland-nosystemd-git
- #CC=clang CXX="clang++" CC_LD=lld CXX_LD=lld meson setup build \
meson setup build \
--prefix /usr \
--libexecdir lib \
@@ -123,9 +122,6 @@ package() {
--destdir "$pkgdir" \
--skip-subprojects hyprland-protocols
- mkdir -p "$pkgdir/usr/include/hyprland/wlroots"
- mv "$pkgdir/usr/include/wlr" "$pkgdir/usr/include/hyprland/wlroots"
-
# FIXME: remove after xdg-desktop-portal-hyprland disowns hyprland-portals.conf
rm -rf "$pkgdir/usr/share/xdg-desktop-portal"