summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiroro-hs2024-05-11 20:14:15 +0900
committerPiroro-hs2024-05-11 20:14:15 +0900
commit09c738e2c939e5ba49a1e495ce38188e560794d7 (patch)
tree0aec49ed836a7cf6496cce8dcd9a646e5577b0ec
parent9d22b1297c08641d6d04e3cde8c8c6e2898b1f5d (diff)
downloadaur-hyprland-nox.tar.gz
0.40.0
-rw-r--r--.SRCINFO10
-rw-r--r--0001-core-chase-hyprwayland-scanner.patch54
-rw-r--r--PKGBUILD17
3 files changed, 72 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 24f20b8dc091..d31410227beb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hyprland-nox
pkgdesc = A dynamic tiling Wayland compositor based on wlroots that doesn't sacrifice on its looks. (w/o XWayland support)
- pkgver = 0.39.1
+ pkgver = 0.40.0
pkgrel = 1
url = https://github.com/hyprwm/Hyprland
arch = x86_64
@@ -8,6 +8,7 @@ pkgbase = hyprland-nox
makedepends = cmake
makedepends = git
makedepends = hwdata
+ makedepends = hyprwayland-scanner
makedepends = meson
makedepends = ninja
makedepends = wayland-protocols
@@ -29,19 +30,22 @@ pkgbase = hyprland-nox
depends = seatd
depends = systemd-libs
depends = tomlplusplus
+ depends = util-linux-libs
depends = wayland
optdepends = cmake: to build and install plugins using hyprpm
optdepends = cpio: to build and install plugins using hyprpm
optdepends = meson: to build and install plugins using hyprpm
provides = hyprland
conflicts = hyprland
- source = hyprland-nox::git+https://github.com/hyprwm/Hyprland#tag=v0.39.1
+ source = hyprland-nox::git+https://github.com/hyprwm/Hyprland#tag=v0.40.0
source = hyprland-nox_wlroots-hyprland::git+https://github.com/hyprwm/wlroots-hyprland.git
source = hyprland-nox_hyprland-protocols::git+https://github.com/hyprwm/hyprland-protocols.git
source = hyprland-nox_udis86::git+https://github.com/canihavesomecoffee/udis86.git
- sha256sums = 64cb3ae405a1282f15e1382d996683b080bf2d193861049420a7ea510c5fe95b
+ source = 0001-core-chase-hyprwayland-scanner.patch
+ sha256sums = 13a2f6da9afa5001bb745110d45d3a280a813ab5c9b838b0342cab461ff2ba7c
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = 7445eb076ae0aa13492ecf99097e93cf8940c83185a957a77fb063e7fbc92ac8
pkgname = hyprland-nox
diff --git a/0001-core-chase-hyprwayland-scanner.patch b/0001-core-chase-hyprwayland-scanner.patch
new file mode 100644
index 000000000000..61aee51fb00b
--- /dev/null
+++ b/0001-core-chase-hyprwayland-scanner.patch
@@ -0,0 +1,54 @@
+From ec092bd601d9d351ff6ca34bd97f12055b2a4dd9 Mon Sep 17 00:00:00 2001
+From: Vaxry <vaxry@vaxry.net>
+Date: Tue, 7 May 2024 14:26:26 +0100
+Subject: [PATCH] core: chase hyprwayland-scanner
+
+---
+ flake.lock | 6 +++---
+ src/protocols/OutputManagement.cpp | 4 ++--
+ 2 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/flake.lock b/flake.lock
+index 976553d3..4dc7da82 100644
+--- a/flake.lock
++++ b/flake.lock
+@@ -84,11 +84,11 @@
+ ]
+ },
+ "locked": {
+- "lastModified": 1714755542,
+- "narHash": "sha256-D0pg+ZRwrt4lavZ97Ca8clsgbPA3duLj8iEM7riaIFY=",
++ "lastModified": 1715088365,
++ "narHash": "sha256-cVH43+fiiCXqr6F2vUA8KmNI9ytWIQoZGnVz0IpBbZw=",
+ "owner": "hyprwm",
+ "repo": "hyprwayland-scanner",
+- "rev": "1270ebaa539e56d61b708c24b072b09cbbd3a828",
++ "rev": "6119dc2a965fd30ffa45c50a8398d5da3150df4c",
+ "type": "github"
+ },
+ "original": {
+diff --git a/src/protocols/OutputManagement.cpp b/src/protocols/OutputManagement.cpp
+index 9ebcba07..e7779726 100644
+--- a/src/protocols/OutputManagement.cpp
++++ b/src/protocols/OutputManagement.cpp
+@@ -166,7 +166,7 @@ void COutputHead::sendAllData() {
+ LOGM(LOG, " | sending current mode for {}: {}x{}@{}", pMonitor->szName, m->mode->width, m->mode->height, m->mode->refresh);
+ else
+ LOGM(LOG, " | sending current mode for {}: null (fake)", pMonitor->szName);
+- resource->sendCurrentMode(m->resource->resource());
++ resource->sendCurrentMode(m->resource.get());
+ break;
+ }
+ }
+@@ -197,7 +197,7 @@ void COutputHead::updateMode() {
+ LOGM(LOG, " | sending current mode for {}: {}x{}@{}", pMonitor->szName, m->mode->width, m->mode->height, m->mode->refresh);
+ else
+ LOGM(LOG, " | sending current mode for {}: null (fake)", pMonitor->szName);
+- resource->sendCurrentMode(m->resource->resource());
++ resource->sendCurrentMode(m->resource.get());
+ break;
+ }
+ }
+--
+2.45.0
+
diff --git a/PKGBUILD b/PKGBUILD
index bf8f2d5350de..3cbfe76db2f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: Piroro-hs
pkgname=hyprland-nox
-pkgver=0.39.1
+pkgver=0.40.0
pkgrel=1
pkgdesc="A dynamic tiling Wayland compositor based on wlroots that doesn't sacrifice on its looks. (w/o XWayland support)"
arch=('x86_64')
-url="https://github.com/hyprwm/Hyprland"
+url='https://github.com/hyprwm/Hyprland'
license=('BSD-3-Clause')
groups=()
depends=('cairo'
@@ -26,10 +26,12 @@ depends=('cairo'
'seatd'
'systemd-libs'
'tomlplusplus'
+ 'util-linux-libs'
'wayland')
makedepends=('cmake'
'git'
'hwdata'
+ 'hyprwayland-scanner'
'meson'
'ninja'
'wayland-protocols')
@@ -43,11 +45,13 @@ backup=()
source=("$pkgname::git+$url#tag=v$pkgver"
"${pkgname}_wlroots-hyprland::git+https://github.com/hyprwm/wlroots-hyprland.git"
"${pkgname}_hyprland-protocols::git+https://github.com/hyprwm/hyprland-protocols.git"
- "${pkgname}_udis86::git+https://github.com/canihavesomecoffee/udis86.git")
-sha256sums=('64cb3ae405a1282f15e1382d996683b080bf2d193861049420a7ea510c5fe95b'
+ "${pkgname}_udis86::git+https://github.com/canihavesomecoffee/udis86.git"
+ '0001-core-chase-hyprwayland-scanner.patch')
+sha256sums=('13a2f6da9afa5001bb745110d45d3a280a813ab5c9b838b0342cab461ff2ba7c'
'SKIP'
'SKIP'
- 'SKIP')
+ 'SKIP'
+ '7445eb076ae0aa13492ecf99097e93cf8940c83185a957a77fb063e7fbc92ac8')
prepare() {
cd "$srcdir/$pkgname"
@@ -57,6 +61,7 @@ prepare() {
git config submodule.subprojects/hyprland-protocols.url "$srcdir/${pkgname}_hyprland-protocols"
git config submodule.subprojects/udis86.url "$srcdir/${pkgname}_udis86"
git -c protocol.file.allow=always submodule update
+ patch -p1 -i ../0001-core-chase-hyprwayland-scanner.patch
}
build() {
@@ -67,7 +72,7 @@ build() {
package() {
cd "$srcdir/$pkgname"
- make PREFIX="$pkgdir/usr" MAKEFLAGS="-o installheaders" install
+ make PREFIX="$pkgdir/usr" MAKEFLAGS='-o installheaders' install
rm -rf "$pkgdir/usr/share/xdg-desktop-portal"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}