summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMonstrousOgre2023-03-15 07:03:27 +0530
committerMonstrousOgre2023-03-15 07:03:27 +0530
commit01c69bdc1c89e9c41b86da5b4ce3cd119dae3a3c (patch)
tree93f4c072f20173dbd11d2f2847dd6e164d7f53d8
parent6e1114f6233d80d2971a0280f9bc32f0d1b1faa2 (diff)
downloadaur-01c69bdc1c89e9c41b86da5b4ce3cd119dae3a3c.tar.gz
Update to v0.23.0beta
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
2 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 76b0b261ed42..464d29727928 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hyprland-nvidia
pkgdesc = A dynamic tiling Wayland compositor based on wlroots that doesn't sacrifice on its looks. (NVIDIA patch)
- pkgver = 0.22.0beta
+ pkgver = 0.23.0beta
pkgrel = 1
url = https://github.com/hyprwm/Hyprland
arch = any
@@ -42,14 +42,16 @@ pkgbase = hyprland-nvidia
depends = vulkan-icd-loader
depends = vulkan-validation-layers
depends = xorg-xwayland
+ depends = libliftoff
+ depends = libdisplay-info
provides = hyprland
conflicts = hyprland
options = !makeflags
options = !buildflags
options = !strip
- source = hyprland-nvidia-0.22.0beta.tar.gz::https://github.com/hyprwm/Hyprland/releases/download/v0.22.0beta/source-v0.22.0beta.tar.gz
+ source = hyprland-nvidia-0.23.0beta.tar.gz::https://github.com/hyprwm/Hyprland/releases/download/v0.23.0beta/source-v0.23.0beta.tar.gz
source = nvidia.patch
- sha256sums = 4f8d20a12080926761913a2c7de136f77b718949667f4f2a4974ad34708fe524
+ sha256sums = 779c35b0256cffe681586e4c34d63cf46fe4f263eff5370d06ae77a96e5de01f
sha256sums = 522b19656d7c1627ec615b6720182590570560e346c1670f9df002015707b340
pkgname = hyprland-nvidia
diff --git a/PKGBUILD b/PKGBUILD
index 67b6f01ef538..30442c5c5a55 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname="hyprland"
pkgname="${_pkgname}-nvidia"
-pkgver="0.22.0beta"
+pkgver="0.23.0beta"
pkgrel=1
pkgdesc="A dynamic tiling Wayland compositor based on wlroots that doesn't sacrifice on its looks. (NVIDIA patch)"
arch=(any)
@@ -36,7 +36,9 @@ depends=(
seatd
vulkan-icd-loader
vulkan-validation-layers
- xorg-xwayland)
+ xorg-xwayland
+ libliftoff
+ libdisplay-info)
makedepends=(
git
cmake
@@ -51,7 +53,7 @@ source=("${pkgname}-${pkgver}.tar.gz::https://github.com/hyprwm/Hyprland/release
"nvidia.patch")
conflicts=("${_pkgname}")
provides=(hyprland)
-sha256sums=('4f8d20a12080926761913a2c7de136f77b718949667f4f2a4974ad34708fe524'
+sha256sums=('779c35b0256cffe681586e4c34d63cf46fe4f263eff5370d06ae77a96e5de01f'
'522b19656d7c1627ec615b6720182590570560e346c1670f9df002015707b340')
options=(!makeflags !buildflags !strip)
@@ -60,7 +62,8 @@ build() {
make fixwlr
patch --directory="$srcdir/hyprland-source/subprojects/wlroots/" --forward --strip=0 \
--input="${srcdir}/../nvidia.patch"
- cd "./subprojects/wlroots/" && meson build/ --prefix="${srcdir}/tmpwlr" --buildtype=release && ninja -C build/ && mkdir -p "${srcdir}/tmpwlr" && ninja -C build/ install && cd ../../
+ cd "./subprojects/wlroots/" && meson build/ --prefix="${srcdir}/tmpwlr" --buildtype=release && ninja -C build/ && mkdir -p "${srcdir}/tmpwlr" && ninja -C build/ install && cd ../
+ cd udis86 && cmake --no-warn-unused-cli -DCMAKE_BUILD_TYPE:STRING=Release -H./ -B./build -G Ninja && cmake --build ./build --config Release --target all -j$(shell nproc) && cd ../..
make protocols
make release
cd ./hyprctl && make all && cd ..