summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMickhat2023-10-16 20:27:29 +0200
committerMickhat2023-10-16 20:27:29 +0200
commita4beca30cac6745a4a20feddebc7ab687f48bc3c (patch)
treed8391b5907f928b4a4ce9364bd0ef9e6532a44ca
parent45d6a4b918e4ab6fc70feefc87355efd3969dcba (diff)
downloadaur-a4beca30cac6745a4a20feddebc7ab687f48bc3c.tar.gz
update v0.31.0
-rwxr-xr-x.SRCINFO6
-rwxr-xr-xPKGBUILD8
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e2b39b4c61db..d1198334fb88 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hyprland-nvidia
pkgdesc = A dynamic tiling Wayland compositor based on wlroots that doesn't sacrifice on its looks. (NVIDIA patch)
- pkgver = 0.30.0
+ pkgver = 0.31.0
pkgrel = 1
url = https://github.com/hyprwm/Hyprland
arch = any
@@ -49,9 +49,9 @@ pkgbase = hyprland-nvidia
options = !makeflags
options = !buildflags
options = !strip
- source = hyprland-nvidia-0.30.0.tar.gz::https://github.com/hyprwm/Hyprland/releases/download/v0.30.0/source-v0.30.0.tar.gz
+ source = hyprland-nvidia-0.31.0.tar.gz::https://github.com/hyprwm/Hyprland/releases/download/v0.31.0/source-v0.31.0.tar.gz
source = nvidia.patch
- sha256sums = 68a79b2c1ae1a56c046e6ecf07f0b3a8135461d387f6ad0d8f0623a7f300ca80
+ sha256sums = 863bf5ba1051f223a30efeb0160846784e9b68266d95c7a1c8bac36b19122536
sha256sums = 10223a97a622ea7e641b4305a9a4f7bf0cb0526dacfbfa5970171558b3a63488
pkgname = hyprland-nvidia
diff --git a/PKGBUILD b/PKGBUILD
index e2af4eacd39b..7493ec2985c0 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname="hyprland"
pkgname="${_pkgname}-nvidia"
-pkgver="0.30.0"
+pkgver="0.31.0"
pkgrel=1
pkgdesc="A dynamic tiling Wayland compositor based on wlroots that doesn't sacrifice on its looks. (NVIDIA patch)"
arch=(any)
@@ -53,13 +53,12 @@ source=("${pkgname}-${pkgver}.tar.gz::https://github.com/hyprwm/Hyprland/release
"nvidia.patch")
conflicts=("${_pkgname}")
provides=(hyprland)
-sha256sums=('68a79b2c1ae1a56c046e6ecf07f0b3a8135461d387f6ad0d8f0623a7f300ca80'
+sha256sums=('863bf5ba1051f223a30efeb0160846784e9b68266d95c7a1c8bac36b19122536'
'10223a97a622ea7e641b4305a9a4f7bf0cb0526dacfbfa5970171558b3a63488')
options=(!makeflags !buildflags !strip)
build() {
cd "$srcdir/hyprland-source"
- make fixwlr
patch --directory="$srcdir/hyprland-source/subprojects/wlroots/" --forward --strip=0 \
--input="${srcdir}/nvidia.patch"
cd "./subprojects/wlroots/" && meson build/ --prefix="${srcdir}/tmpwlr" --buildtype=release && ninja -C build/ && mkdir -p "${srcdir}/tmpwlr" && ninja -C build/ install && cd ../
@@ -79,5 +78,6 @@ package() {
install -Dm644 hyprland-source/example/hyprland.desktop -t "${pkgdir}/usr/share/wayland-sessions"
install -Dm644 hyprland-source/example/hyprland.conf -t "${pkgdir}/usr/share/hyprland"
install -Dm644 hyprland-source/LICENSE -t "${pkgdir}/usr/share/licenses/${_pkgname}"
- install -Dm755 "${srcdir}/tmpwlr/lib/libwlroots.so.12032" -t "${pkgdir}/usr/lib"
+ mv "${srcdir}/tmpwlr/lib/libwlroots.so.12" "${srcdir}/tmpwlr/lib/libwlroots.so.12032".
+ #install -Dm755 "${srcdir}/tmpwlr/lib/libwlroots.so.12032" -t "${pkgdir}/usr/lib"
}