summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortohmais2023-03-04 11:07:58 +1000
committertohmais2023-03-04 11:07:58 +1000
commitd640892cb253d4a99ba170277a235b54cdc00e5d (patch)
tree6b1bdb763ccc1b143518ba3677c2ca53c43a1d99
parent3263fd0c3e2cb35a512d9939d4fe77f29f285f38 (diff)
downloadaur-d640892cb253d4a99ba170277a235b54cdc00e5d.tar.gz
update deps, remove screenshare patch
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
-rw-r--r--nvidia.patch28
3 files changed, 11 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 60dc5e004716..838ce4ddff6a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hyprland-nvidia-git
pkgdesc = A dynamic tiling Wayland compositor based on wlroots that doesn't sacrifice on its looks. (NVIDIA patch)
- pkgver = r2042.ga7ed3a5
+ pkgver = r2550.31cd1042
pkgrel = 1
url = https://github.com/hyprwm/Hyprland
arch = any
@@ -42,6 +42,8 @@ pkgbase = hyprland-nvidia-git
depends = vulkan-icd-loader
depends = vulkan-validation-layers
depends = xorg-xwayland
+ depends = libliftoff
+ depends = libdisplay-info
provides = hyprland
conflicts = hyprland
options = !makeflags
@@ -50,6 +52,6 @@ pkgbase = hyprland-nvidia-git
source = hyprland::git+https://github.com/hyprwm/Hyprland.git
source = nvidia.patch
sha256sums = SKIP
- sha256sums = 522b19656d7c1627ec615b6720182590570560e346c1670f9df002015707b340
+ sha256sums = c200d341641ee20a13b1893e27a9d823e9ef5ac2378e3cdecd0efc55a713db1c
pkgname = hyprland-nvidia-git
diff --git a/PKGBUILD b/PKGBUILD
index bbad289af972..1de440f59077 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname="hyprland"
pkgname="${_pkgname}-nvidia-git"
-pkgver=r2042.ga7ed3a5
+pkgver=r2550.31cd1042
pkgrel=1
pkgdesc="A dynamic tiling Wayland compositor based on wlroots that doesn't sacrifice on its looks. (NVIDIA patch)"
arch=(any)
@@ -36,7 +36,9 @@ depends=(
seatd
vulkan-icd-loader
vulkan-validation-layers
- xorg-xwayland)
+ xorg-xwayland
+ libliftoff
+ libdisplay-info)
makedepends=(
git
cmake
@@ -52,7 +54,7 @@ source=("${_pkgname}::git+https://github.com/hyprwm/Hyprland.git"
conflicts=("${_pkgname}")
provides=(hyprland)
sha256sums=('SKIP'
- '522b19656d7c1627ec615b6720182590570560e346c1670f9df002015707b340')
+ 'c200d341641ee20a13b1893e27a9d823e9ef5ac2378e3cdecd0efc55a713db1c')
options=(!makeflags !buildflags !strip)
pkgver() {
@@ -69,7 +71,8 @@ build() {
make fixwlr
patch --directory="$srcdir/$_pkgname/subprojects/wlroots/" --forward --strip=0 \
--input="${srcdir}/../nvidia.patch"
- cd "./subprojects/wlroots/" && meson build/ --prefix="${srcdir}/tmpwlr" --buildtype=release && ninja -C build/ && mkdir -p "${srcdir}/tmpwlr" && ninja -C build/ install && cd ../../
+ cd "./subprojects/wlroots/" && meson build/ --prefix="${srcdir}/tmpwlr" --buildtype=release && ninja -C build/ && mkdir -p "${srcdir}/tmpwlr" && ninja -C build/ install && cd ../
+ cd udis86 && cmake --no-warn-unused-cli -DCMAKE_BUILD_TYPE:STRING=Release -H./ -B./build -G Ninja && cmake --build ./build --config Release --target all -j$(shell nproc) && cd ../..
make protocols
make release
cd ./hyprctl && make all && cd ..
diff --git a/nvidia.patch b/nvidia.patch
index 2f0103c8bad8..6abd4de2d209 100644
--- a/nvidia.patch
+++ b/nvidia.patch
@@ -9,31 +9,3 @@ diff --unified --recursive --text hyprland-test/src/hyprland/subprojects/wlroots
+ glFinish();
glBindFramebuffer(GL_FRAMEBUFFER, 0);
pop_gles2_debug(renderer);
-
-diff --unified --recursive --text hyprland-test/src/hyprland/subprojects/wlroots/types/output/render.c hyprland-git/src/hyprland/subprojects/wlroots/types/output/render.c
---- types/output/render.c 2022-10-23 11:18:56.598893482 +1000
-+++ types/output/render.c 2022-10-23 11:15:15.110308366 +1000
-@@ -325,22 +325,7 @@
- }
-
- uint32_t wlr_output_preferred_read_format(struct wlr_output *output) {
-- struct wlr_renderer *renderer = output->renderer;
-- assert(renderer != NULL);
--
-- if (!renderer->impl->preferred_read_format || !renderer->impl->read_pixels) {
-- return DRM_FORMAT_INVALID;
-- }
--
-- if (!output_attach_back_buffer(output, &output->pending, NULL)) {
-- return false;
-- }
--
-- uint32_t fmt = renderer->impl->preferred_read_format(renderer);
--
-- output_clear_back_buffer(output);
--
-- return fmt;
-+ return DRM_FORMAT_XRGB8888;
- }
-
- bool output_is_direct_scanout(struct wlr_output *output,