summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeremy Kescher2023-11-30 00:02:13 +0100
committerJeremy Kescher2023-11-30 00:02:13 +0100
commit21ba0d07159af1e72be17a396f924ee2534443ff (patch)
treea564691240e141bb1a003bcaa0db4dce8184acca
parentf8e1d4e417566275eb9d8be11101c12d083c9aac (diff)
downloadaur-21ba0d07159af1e72be17a396f924ee2534443ff.tar.gz
Rename packages, add hyprtrails and hyprwinwrap
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD48
2 files changed, 48 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c9ebd52360c9..e789e1708d4d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,32 @@
pkgbase = hyprland-plugins-git
pkgdesc = Official plugins for hyprland
- pkgver = r43.16dc292
+ pkgver = r92.b225987
pkgrel = 1
url = https://github.com/hyprwm/hyprland-plugins
arch = x86_64
arch = aarch64
license = BSD
- makedepends = hyprland
+ makedepends = hyprland-git
makedepends = git
source = hyprland-plugins-git::git+https://github.com/hyprwm/hyprland-plugins.git
sha256sums = SKIP
-pkgname = borders-plus-plus-git
+pkgname = hyprland-plugin-borders-plus-plus-git
pkgdesc = Hyprland plugin that allows you to add one or two additional borders to your windows
- provides = borders-plus-plus
- conflicts = borders-plus-plus
+ provides = hyprland-plugin-borders-plus-plus
-pkgname = csgo-vulkan-fix-git
+pkgname = hyprland-plugin-csgo-vulkan-fix-git
pkgdesc = Hyprland plugin that allows you to pick any resolution in CS:GO when using Vulkan
- provides = csgo-vulkan-fix
- conflicts = csgo-vulkan-fix
+ provides = hyprland-plugin-csgo-vulkan-fix
-pkgname = hyprbars-git
+pkgname = hyprland-plugin-hyprbars-git
pkgdesc = Hyprland plugin that adds simple title bars to windows
- provides = hyprbars
- conflicts = hyprbars
+ provides = hyprland-plugin-hyprbars
+
+pkgname = hyprland-plugin-hyprtrails-git
+ pkgdesc = Hyprland plugin that adds trails behind windows
+ provides = hyprland-plugin-hyprtrails
+
+pkgname = hyprland-plugin-hyprwinwrap-git
+ pkgdesc = Hyprland plugin that acts like Xwinwrap.
+ provides = hyprland-plugin-hyprwinwrap
diff --git a/PKGBUILD b/PKGBUILD
index 647a19cabcba..624a555b820c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Jeremy Kescher <jeremy@kescher.at>
pkgbase=hyprland-plugins-git
-pkgname=(borders-plus-plus-git csgo-vulkan-fix-git hyprbars-git)
-pkgver=r43.16dc292
+pkgname=(hyprland-plugin-borders-plus-plus-git hyprland-plugin-csgo-vulkan-fix-git hyprland-plugin-hyprbars-git hyprland-plugin-hyprtrails-git hyprland-plugin-hyprwinwrap-git)
+pkgver=r92.b225987
pkgrel=1
pkgdesc="Official plugins for hyprland"
arch=(x86_64 aarch64)
url="https://github.com/hyprwm/hyprland-plugins"
license=('BSD')
-makedepends=(hyprland git)
+makedepends=(hyprland-git git)
source=($pkgbase::git+https://github.com/hyprwm/hyprland-plugins.git)
sha256sums=('SKIP')
@@ -19,8 +19,9 @@ pkgver() {
build() {
cd "$srcdir/$pkgbase"
-
+
for pkg in ${pkgname[@]}; do
+ pkg=${pkg##hyprland-plugin-}
pushd ${pkg%%-git} >/dev/null
make all &
popd >/dev/null
@@ -28,32 +29,47 @@ build() {
wait
}
-package_borders-plus-plus-git() {
- provides=(borders-plus-plus)
- conflicts=(borders-plus-plus)
+package_hyprland-plugin-borders-plus-plus-git() {
+ provides=(hyprland-plugin-borders-plus-plus)
pkgdesc="Hyprland plugin that allows you to add one or two additional borders to your windows"
cd "$srcdir/$pkgbase/borders-plus-plus"
install -Dm755 borders-plus-plus.so "$pkgdir/usr/lib/hyprland-plugins/borders-plus-plus.so"
- install -Dm644 ../LICENSE "$pkgdir/usr/share/licenses/borders-plus-plus-git/LICENSE"
+ install -Dm644 ../LICENSE "$pkgdir/usr/share/licenses/hyprland-plugin-borders-plus-plus-git/LICENSE"
}
-package_csgo-vulkan-fix-git() {
- provides=(csgo-vulkan-fix)
- conflicts=(csgo-vulkan-fix)
+package_hyprland-plugin-csgo-vulkan-fix-git() {
+ provides=(hyprland-plugin-csgo-vulkan-fix)
pkgdesc="Hyprland plugin that allows you to pick any resolution in CS:GO when using Vulkan"
cd "$srcdir/$pkgbase/csgo-vulkan-fix"
install -Dm755 csgo-vulkan-fix.so "$pkgdir/usr/lib/hyprland-plugins/csgo-vulkan-fix.so"
- install -Dm644 ../LICENSE "$pkgdir/usr/share/licenses/csgo-vulkan-fix-git/LICENSE"
+ install -Dm644 ../LICENSE "$pkgdir/usr/share/licenses/hyprland-plugin-csgo-vulkan-fix-git/LICENSE"
}
-package_hyprbars-git() {
- provides=(hyprbars)
- conflicts=(hyprbars)
+package_hyprland-plugin-hyprbars-git() {
+ provides=(hyprland-plugin-hyprbars)
pkgdesc="Hyprland plugin that adds simple title bars to windows"
cd "$srcdir/$pkgbase/hyprbars"
install -Dm755 hyprbars.so "$pkgdir/usr/lib/hyprland-plugins/hyprbars.so"
- install -Dm644 ../LICENSE "$pkgdir/usr/share/licenses/hyprbars-git/LICENSE"
+ install -Dm644 ../LICENSE "$pkgdir/usr/share/licenses/hyprland-plugin-hyprbars-git/LICENSE"
+}
+
+package_hyprland-plugin-hyprtrails-git() {
+ provides=(hyprland-plugin-hyprtrails)
+ pkgdesc="Hyprland plugin that adds trails behind windows"
+
+ cd "$srcdir/$pkgbase/hyprtrails"
+ install -Dm755 hyprtrails.so "$pkgdir/usr/lib/hyprland-plugins/hyprtrails.so"
+ install -Dm644 ../LICENSE "$pkgdir/usr/share/licenses/hyprland-plugin-hyprtrails-git/LICENSE"
+}
+
+package_hyprland-plugin-hyprwinwrap-git() {
+ provides=(hyprland-plugin-hyprwinwrap)
+ pkgdesc="Hyprland plugin that acts like Xwinwrap."
+
+ cd "$srcdir/$pkgbase/hyprwinwrap"
+ install -Dm755 hyprwinwrap.so "$pkgdir/usr/lib/hyprland-plugins/hyprwinwrap.so"
+ install -Dm644 ../LICENSE "$pkgdir/usr/share/licenses/hyprland-plugin-hyprwinwrap-git/LICENSE"
}