summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Bernard2023-07-10 04:36:24 -0500
committerJohn Bernard2023-07-10 04:36:24 -0500
commit2e78606aee0abdf37975b8a835ccada9ba41d1b2 (patch)
tree4dcc8cc74522eb28c1584fa7fb7a1c3086ab2514
parent24c9ef76b15d6777271916e6b146421dbdeeb215 (diff)
downloadaur-2e78606aee0abdf37975b8a835ccada9ba41d1b2.tar.gz
minor edits
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1df81e5c0bdd..bb212259dbc3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,13 +17,13 @@ depends=(
util-linux
)
makedepends=(git python-{build,installer})
-provides=("$_pkgname")
-conflicts=("$_pkgname")
+provides=($_pkgname)
+conflicts=($_pkgname)
source=(git+https://github.com/loqusion/${_pkgname}.git)
sha512sums=('SKIP')
pkgver() {
- cd "$_pkgname"
+ cd $_pkgname
{
set -o pipefail
git describe --long 2>/dev/null | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
@@ -32,11 +32,11 @@ pkgver() {
}
build() {
- cd "$_pkgname"
+ cd $_pkgname
python -m build -wn
}
package() {
- cd "$_pkgname"
+ cd $_pkgname
PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer -d "$pkgdir" dist/*.whl
}