summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGitHub Action2023-07-14 11:03:14 +0000
committerGitHub Action2023-07-14 11:03:14 +0000
commitbf6611da2947c21a6cac312eafd25f4c919c5298 (patch)
tree2601483b3e63cf5cfdaa0f572a0cd087b725607c
parent4f207c6f2f8baf5aa443c342759fa8145220094d (diff)
downloadaur-bf6611da2947c21a6cac312eafd25f4c919c5298.tar.gz
Update from GitHub Actions: Use system python
`python` can sometimes refer to a venv `python` or be managed by e.g. rtx; I've dealt with issues with python package installations that failed silently before and it can get very annoying. https://github.com/loqusion/aur-packages/actions/runs/5553387503
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7beadf2b9823..ef0b7ee917bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -38,13 +38,13 @@ pkgver() {
build() {
cd $_pkgname
- python -m build --wheel --no-isolation
+ /usr/bin/python -m build --wheel --no-isolation
}
package() {
cd $_pkgname
export PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/"
- python -m installer --destdir="$pkgdir" dist/*.whl
+ /usr/bin/python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm0644 -t "$pkgdir/usr/share/licenses/$_pkgname/" LICENSE
install -Dm0644 -t "$pkgdir/usr/share/$_pkgname/shaders/" shaders/*
install -Dm0644 -t "$pkgdir/usr/share/$_pkgname/examples/" examples/*