summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorskydrome2019-10-23 00:36:10 -0400
committerskydrome2019-10-23 00:36:10 -0400
commit25fc0bab1db07db3b8a7ae425f81c0fb26239e56 (patch)
treefa977f3a218f895ad204ebdd052c22b1dd99ce8d
parent9889cce7a2823c9b09d55cc6e2b1ab64964e05c4 (diff)
downloadaur-25fc0bab1db07db3b8a7ae425f81c0fb26239e56.tar.gz
fix translations on jdk13
-rw-r--r--PKGBUILD13
-rw-r--r--gettext-0.20.1-jdk13-fix.patch120
2 files changed, 130 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a08b4414b582..ef704f79b1b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: skydrome <skydrome@protonmail.com>
# Uncomment if you do not want to build all language translations
-export LG2=en
+#export LG2=en
pkgname=i2p
pkgver=0.9.43
@@ -28,14 +28,21 @@ validpgpkeys=('2D3D2D03910C6504C1210C65EE60C0C8EE7256A8')
_url="https://launchpad.net/i2p/trunk/${pkgver}/+download"
source=("${_url}/i2psource_${pkgver}.tar.bz2"{,.sig}
- 'i2prouter.service' 'i2prouter.sh' 'wrapper.config' 'router.config')
+ 'i2prouter.service' 'i2prouter.sh' 'wrapper.config' 'router.config'
+ 'gettext-0.20.1-jdk13-fix.patch')
sha256sums=('beb2a3c62efce826cd5aa3e296b483143ad2c581ddb038677f960f7d110df81c'
'SKIP'
'9bb899ece87099716da29bac8b7da02916fc325699b68989e73c1fe333a6342f'
'ea8f97e66461d591b1819eab39bbc40056b89ae12f7729b3dd9fd2ce088e5e53'
'5d134ee5bc614b54ec48de7c5214f6dbe08abcfab7d286c5b1c7616e39b478ed'
- '7a4688db826c3dddb762976cd8c9a5d465255c3577069243d8e5af941a4126e2')
+ '7a4688db826c3dddb762976cd8c9a5d465255c3577069243d8e5af941a4126e2'
+ '79e5c8077b479a2edaaaf15a427084c2e87c16cda80ed2230f9354dcdca14393')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch -Np0 -i "$srcdir/gettext-0.20.1-jdk13-fix.patch"
+}
build() {
cd "$pkgname-$pkgver"
diff --git a/gettext-0.20.1-jdk13-fix.patch b/gettext-0.20.1-jdk13-fix.patch
new file mode 100644
index 000000000000..a0eefa3f2536
--- /dev/null
+++ b/gettext-0.20.1-jdk13-fix.patch
@@ -0,0 +1,120 @@
+diff -Naur apps/desktopgui/bundle-messages.sh apps/desktopgui/bundle-messages.sh
+--- apps/desktopgui/bundle-messages.sh 2019-10-21 15:51:13.000000000 -0400
++++ apps/desktopgui/bundle-messages.sh 2019-10-23 00:05:49.425382182 -0400
+@@ -105,7 +105,7 @@
+ # only generate for non-source language
+ echo "Generating ${CLASS}_$LG ResourceBundle..."
+
+- msgfmt -V | grep -q '0\.19'
++ msgfmt -V | grep -q '0\.2[01]'
+ if [ $? -ne 0 ]
+ then
+ # slow way
+diff -Naur apps/i2psnark/java/bundle-messages.sh apps/i2psnark/java/bundle-messages.sh
+--- apps/i2psnark/java/bundle-messages.sh 2019-10-21 15:51:14.000000000 -0400
++++ apps/i2psnark/java/bundle-messages.sh 2019-10-23 00:05:49.428715395 -0400
+@@ -96,7 +96,7 @@
+ # only generate for non-source language
+ echo "Generating ${CLASS}_$LG ResourceBundle..."
+
+- msgfmt -V | grep -q '0\.19'
++ msgfmt -V | grep -q '0\.2[01]'
+ if [ $? -ne 0 ]
+ then
+ # slow way
+diff -Naur apps/i2ptunnel/java/bundle-messages-proxy.sh apps/i2ptunnel/java/bundle-messages-proxy.sh
+--- apps/i2ptunnel/java/bundle-messages-proxy.sh 2019-10-21 15:51:14.000000000 -0400
++++ apps/i2ptunnel/java/bundle-messages-proxy.sh 2019-10-23 00:05:49.435381820 -0400
+@@ -98,7 +98,7 @@
+ # only generate for non-source language
+ echo "Generating ${CLASS}_$LG ResourceBundle..."
+
+- msgfmt -V | grep -q '0\.19'
++ msgfmt -V | grep -q '0\.2[01]'
+ if [ $? -ne 0 ]
+ then
+ # slow way
+diff -Naur apps/i2ptunnel/java/bundle-messages.sh apps/i2ptunnel/java/bundle-messages.sh
+--- apps/i2ptunnel/java/bundle-messages.sh 2019-10-21 15:51:14.000000000 -0400
++++ apps/i2ptunnel/java/bundle-messages.sh 2019-10-23 00:05:49.435381820 -0400
+@@ -97,7 +97,7 @@
+ # only generate for non-source language
+ echo "Generating ${CLASS}_$LG ResourceBundle..."
+
+- msgfmt -V | grep -q '0\.19'
++ msgfmt -V | grep -q '0\.2[01]'
+ if [ $? -ne 0 ]
+ then
+ # slow way
+diff -Naur apps/ministreaming/java/bundle-messages.sh apps/ministreaming/java/bundle-messages.sh
+--- apps/ministreaming/java/bundle-messages.sh 2019-10-21 15:51:16.000000000 -0400
++++ apps/ministreaming/java/bundle-messages.sh 2019-10-23 00:05:49.442048246 -0400
+@@ -96,7 +96,7 @@
+ # only generate for non-source language
+ echo "Generating ${CLASS}_$LG ResourceBundle..."
+
+- msgfmt -V | grep -q '0\.19'
++ msgfmt -V | grep -q '0\.2[01]'
+ if [ $? -ne 0 ]
+ then
+ # slow way
+diff -Naur apps/routerconsole/java/bundle-messages-countries.sh apps/routerconsole/java/bundle-messages-countries.sh
+--- apps/routerconsole/java/bundle-messages-countries.sh 2019-10-21 15:51:16.000000000 -0400
++++ apps/routerconsole/java/bundle-messages-countries.sh 2019-10-23 00:05:49.442048246 -0400
+@@ -112,7 +112,7 @@
+ # only generate for non-source language
+ echo "Generating ${CLASS}_$LG ResourceBundle..."
+
+- msgfmt -V | grep -q '0\.19'
++ msgfmt -V | grep -q '0\.2[01]'
+ if [ $? -ne 0 ]
+ then
+ # slow way
+diff -Naur apps/routerconsole/java/bundle-messages-news.sh apps/routerconsole/java/bundle-messages-news.sh
+--- apps/routerconsole/java/bundle-messages-news.sh 2019-10-21 15:51:16.000000000 -0400
++++ apps/routerconsole/java/bundle-messages-news.sh 2019-10-23 00:05:49.452047883 -0400
+@@ -98,7 +98,7 @@
+ # only generate for non-source language
+ echo "Generating ${CLASS}_$LG ResourceBundle..."
+
+- msgfmt -V | grep -q '0\.19'
++ msgfmt -V | grep -q '0\.2[01]'
+ if [ $? -ne 0 ]
+ then
+ # slow way
+diff -Naur apps/routerconsole/java/bundle-messages.sh apps/routerconsole/java/bundle-messages.sh
+--- apps/routerconsole/java/bundle-messages.sh 2019-10-21 15:51:16.000000000 -0400
++++ apps/routerconsole/java/bundle-messages.sh 2019-10-23 00:05:49.452047883 -0400
+@@ -126,7 +126,7 @@
+ # only generate for non-source language
+ echo "Generating ${CLASS}_$LG ResourceBundle..."
+
+- msgfmt -V | grep -q '0\.19'
++ msgfmt -V | grep -q '0\.2[01]'
+ if [ $? -ne 0 ]
+ then
+ # slow way
+diff -Naur apps/susidns/src/bundle-messages.sh apps/susidns/src/bundle-messages.sh
+--- apps/susidns/src/bundle-messages.sh 2019-10-21 15:51:19.000000000 -0400
++++ apps/susidns/src/bundle-messages.sh 2019-10-23 00:05:49.415382545 -0400
+@@ -104,7 +104,7 @@
+ # only generate for non-source language
+ echo "Generating ${CLASS}_$LG ResourceBundle..."
+
+- msgfmt -V | grep -q '0\.19'
++ msgfmt -V | grep -q '0\.2[01]'
+ if [ $? -ne 0 ]
+ then
+ # slow way
+diff -Naur apps/susimail/bundle-messages.sh apps/susimail/bundle-messages.sh
+--- apps/susimail/bundle-messages.sh 2019-10-21 15:51:19.000000000 -0400
++++ apps/susimail/bundle-messages.sh 2019-10-23 00:05:49.418715757 -0400
+@@ -96,7 +96,7 @@
+ # only generate for non-source language
+ echo "Generating ${CLASS}_$LG ResourceBundle..."
+
+- msgfmt -V | grep -q '0\.19'
++ msgfmt -V | grep -q '0\.2[01]'
+ if [ $? -ne 0 ]
+ then
+ # slow way