summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorskydrome2016-10-21 21:57:04 -0400
committerskydrome2016-10-21 21:57:04 -0400
commit94a5a26d56f7713c5089c00709a4d0cada4309f9 (patch)
tree8c72c2cb52a402fa8eedcc5a5c999f8101ea9aa6
parent872d7be33f2b799519470918d6b31ab5064d77dd (diff)
parent8ec23ad972db7b17f2b6a16706cf24efc462776f (diff)
downloadaur-94a5a26d56f7713c5089c00709a4d0cada4309f9.tar.gz
Merge branch 'master' of ssh://aur.archlinux.org/i2p-dev
-rw-r--r--.SRCINFO6
-rwxr-xr-xPKGBUILD8
-rwxr-xr-xrouter.config4
-rwxr-xr-xwrapper.config2
4 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 92f9ca1e806b..1b05285a8d90 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,3 +1,5 @@
+# Generated by mksrcinfo v8
+# Fri Aug 26 18:20:54 UTC 2016
pkgbase = i2p-dev
pkgdesc = A distributed anonymous network (daily mtn->git sync)
pkgver = 0.9.27.2
@@ -28,8 +30,8 @@ pkgbase = i2p-dev
sha256sums = SKIP
sha256sums = ff9942ca43715b5095b0118e306c8aec1af7c68c18e8959dba10d86eac8efbfd
sha256sums = ea8f97e66461d591b1819eab39bbc40056b89ae12f7729b3dd9fd2ce088e5e53
- sha256sums = a76e7b6ccd8f49b51d22012887e1f0101db3bfe6aeebe1bc416b48da4e206b27
- sha256sums = c001f045e52ab82154b21125384dbc4f1d2437376fc65c5d83987051e42b5409
+ sha256sums = 72c0944cd2b04c747673a534475f2ec42c64d52fdda76714f1165c4655113de2
+ sha256sums = 1527afbadcf849ef551b3b7b68d1a29eec316ee620f5320f2933f73ee9924978
pkgname = i2p-dev
diff --git a/PKGBUILD b/PKGBUILD
index a84a7c3100cd..37fce0a0e240 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -39,8 +39,8 @@ source=("git+https://github.com/i2p/${_gitname}.git#commit=${_commit}"
sha256sums=('SKIP'
'ff9942ca43715b5095b0118e306c8aec1af7c68c18e8959dba10d86eac8efbfd'
'ea8f97e66461d591b1819eab39bbc40056b89ae12f7729b3dd9fd2ce088e5e53'
- 'a76e7b6ccd8f49b51d22012887e1f0101db3bfe6aeebe1bc416b48da4e206b27'
- 'c001f045e52ab82154b21125384dbc4f1d2437376fc65c5d83987051e42b5409')
+ '72c0944cd2b04c747673a534475f2ec42c64d52fdda76714f1165c4655113de2'
+ 'b98b00bf7c811089a12a59641e9503bd89447be9d0c0b12bbc780036c7cb6f3c')
pkgver() {
cd "$srcdir/$_gitname"
echo "$(grep 'VERSION =' core/java/src/net/i2p/CoreVersion.java \
@@ -89,7 +89,7 @@ build() {
build_jcpuid
cd "$srcdir/$_gitname"
- ant -Dworkspace.version=$(git rev-parse $_commit) preppkg-linux
+ ant -Dworkspace.version=$(git rev-parse --short $_commit) preppkg-linux
}
package() {
@@ -97,7 +97,7 @@ package() {
install -dm755 "$pkgdir/usr/lib/tmpfiles.d"
install -dm755 "$pkgdir/usr/bin"
- install -dm755 "$pkgdir/opt/i2p"
+ install -dm750 "$pkgdir/opt/i2p"
cp -r pkg-temp/* "$pkgdir/opt/i2p"
cp "$srcdir/wrapper.config" "$pkgdir/opt/i2p"
diff --git a/router.config b/router.config
index cbce544071a7..3635e76d6797 100755
--- a/router.config
+++ b/router.config
@@ -3,7 +3,7 @@
# * IPv6: Disabled
# * In-I2P Network Updates: Disabled
i2cp.disableInterface=true
-i2np.ntcp.ipv6=false
-i2np.udp.ipv6=false
+i2np.udp.addressSources=hidden
router.updateDisabled=true
routerconsole.advanced=true
+i2np.upnp.enable=false
diff --git a/wrapper.config b/wrapper.config
index 4d54e65a668a..284f7eb6abf7 100755
--- a/wrapper.config
+++ b/wrapper.config
@@ -125,7 +125,7 @@ wrapper.jvm_exit.timeout=60
# give the OS 60s to clear all the old sockets / etc before restarting
# Let's change the default from 60 to 10 seconds and see if anyone moans..
-wrapper.restart.delay=10
+wrapper.restart.delay=5
wrapper.ping.interval=300
# The ping timeout must be at least 5 seconds longer than the value of wrapper.ping.interval.