summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordevninja2016-04-10 19:39:27 -0400
committerdevninja2016-04-10 19:39:27 -0400
commit7d8371166e2262cf2139798209b5d6ea0533cdfb (patch)
treec04295ee26958b719f64bf1b7fcdf7acfa55e6ec
downloadaur-7d8371166e2262cf2139798209b5d6ea0533cdfb.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD43
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5d4329775b34
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sun Apr 10 23:39:17 UTC 2016
+pkgbase = i2p-plugin-i2pbote
+ pkgdesc = A distributed email client for I2P
+ pkgver = 0.4.3
+ pkgrel = 1
+ url = http://bote.i2p/
+ arch = any
+ groups = i2p-plugins
+ license = GPLv3
+ makedepends = zip
+ depends = i2p
+ provides = i2pbotes
+ noextract = file://i2pbote.su3
+ source = file://i2pbote.su3
+ sha256sums = 19ae8e09f932d111dc8016e9a3c4f6fa78c059a650d3d735de08d5c1233b7780
+
+pkgname = i2p-plugin-i2pbote
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dae89167feb9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: GI Jack <iamjacksemail@hackermail.com>
+
+# This is a packaged plugin for i2p. It assumes you are using the packaging of
+# i2p as used with the arch i2p package in AUR. This package is to keep all
+# software maintained by the system package manager, and to facilitate
+# redistribution of botes as an arch package
+
+_pluginame=i2pbote
+pkgname=i2p-plugin-${_pluginame}
+pkgver=0.4.3
+pkgrel=1
+pkgdesc="A distributed email client for I2P"
+arch=('any')
+url="http://bote.i2p/"
+license=('GPLv3')
+groups=('i2p-plugins')
+depends=('i2p')
+makedepends=('zip')
+provides=('i2pbotes')
+# get this from http://bote.i2p/i2pbote.su3
+source=("file://${_pluginame}.su3")
+noextract=("file://${_pluginame}.su3")
+sha256sums=('19ae8e09f932d111dc8016e9a3c4f6fa78c059a650d3d735de08d5c1233b7780')
+
+prepare() {
+ cd "${srcdir}"
+
+ local outfile="${_pluginame}.zip"
+ local infile="${_pluginame}.su3"
+
+ #yeah, this is a regular zip file, but with some wierd shit added as a header.
+ # nooo, they couldn't just use an index file like normal people.
+ local -i headlength=70
+ dd if="${infile}" bs=${headlength} skip=1 of="${outfile}"
+ unzip -d i2p "$outfile"
+}
+
+package() {
+ cd "${srcdir}"
+ mkdir -p "${pkgdir}/opt/i2p/.i2p/plugins/"
+ cp -Ra "i2p" "${pkgdir}/opt/i2p/.i2p/plugins/${_pluginame}"
+}
+